• 622阅读
  • 1回复

易语言如何取进程的窗口标题 [复制链接]

上一主题 下一主题
离线啊冲
 

只看楼主 倒序阅读 使用道具 楼主  发表于: 2017-04-01

取窗口句柄吗?

添加API:

.版本 2
.DLL命令 _取窗口句柄, 整数型, "user32.dll", "FindWindowA"
    .参数 窗口类名, 文本型
    .参数 窗口标题, 文本型

代码:
.版本 2
.支持库 spec
.子程序 __启动窗口_创建完毕
.局部变量 窗口类名, 文本型
.局部变量 窗口标题, 文本型
调试输出 (_取窗口句柄 (窗口类名, 窗口标题))







首先根据进程名取PID(进程标识符)
下面是所用的API

.版本 2

.DLL命令 GetAncestor, 整数型, "user32.dll", "GetAncestor", ,
    .参数 hwnd, 整数型
    .参数 gaFlags, 整数型

.DLL命令 GetWindowThreadProcessId, 整数型, "user32", "GetWindowThreadProcessId"
    .参数 hwnd, 整数型
    .参数 lpdwProcessId, 整数型, 传址

.DLL命令 EnumWindows, 整数型, "user32.dll", "EnumWindows"
    .参数 lpEnumFunc, 子程序指针
    .参数 lParam, 整数型, 传址

下面是子程序
调用:进程标示取窗口句柄("这里写PID")

.版本 2

.子程序 进程标示取窗口句柄, 整数型
.参数 进程标示符, 整数型

EnumWindows (&EnumWindowsProc, 进程标示符)
返回 (进程标示符)

.子程序 EnumWindowsProc, 整数型
.参数 hwnd, 整数型
.参数 lParam, 整数型, 参考
.局部变量 lpPid, 整数型
.局部变量 oldPid, 整数型, 静态

.如果真 (oldPid = 0)
    oldPid = lParam
.如果真结束
GetWindowThreadProcessId (hwnd, lpPid)
.如果 (lpPid = oldPid)
    lParam = GetAncestor (hwnd, #GA_ROOTOWNER)
    返回 (0)
.否则
    lParam = 0
    返回 (1)
.如果结束
善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
离线qq3036544906

只看该作者 沙发  发表于: 2017-12-25
分享一下短信轰炸机和语音轰炸机软件+qq747852449 ...
快速回复
限100 字节
如果您在写长篇帖子又不马上发表,建议存为草稿
 
上一个 下一个