刺激战场
  • 3495阅读
  • 3回复

天龙八部自动打怪 [复制链接]

上一主题 下一主题
离线啊冲
 

只看楼主 倒序阅读 使用道具 楼主  发表于: 2013-08-27
— 本帖被 啊冲 从 易语言 移动到本区(2013-10-28) —

.版本 2

.程序集 窗口程序集1
.程序集变量 基址, 整数型

.子程序 __启动窗口_创建完毕
.局部变量 窗口句柄, 整数型
.局部变量 进程ID, 整数型

配置文件 = 取运行目录 () + “\config.ini”
编辑框1.内容 = 读配置项 (配置文件, “设定”, “人物血量”, )
编辑框2.内容 = 读配置项 (配置文件, “设定”, “人物蓝量”, )
编辑框3.内容 = 读配置项 (配置文件, “设定”, “宝宝血量”, )
编辑框5.内容 = 读配置项 (配置文件, “设定”, “打怪时限”, )
窗口句柄 = 窗口取句柄 (“Game.exe”)
按钮8.禁止 = 真
.如果真 (0 ≠ 窗口句柄)
    进程ID = 窗口取进程ID (窗口句柄)
    注册全局热键 (_启动窗口.取窗口句柄 (), 0, #Home键, &自动选择)
    注册全局热键 (_启动窗口.取窗口句柄 (), 0, #End键, &停止选择)
.如果真结束


.子程序 自动选怪
.局部变量 窗口句柄, 整数型
.局部变量 进程ID, 整数型

窗口句柄 = 窗口取句柄 (“Game.exe”)
.如果真 (0 ≠ 窗口句柄)
    进程ID = 窗口取进程ID (窗口句柄)
    按键 (#Ctrl键, 3)
    按键 (#Tab键, 3)
    按键 (#Tab键, 4)
    按键 (#Ctrl键, 4)
.如果真结束


.子程序 自动加血
.局部变量 进程ID, 整数型
.局部变量 窗口句柄, 整数型
.局部变量 基址1, 整数型
.局部变量 一级基址, 整数型
.局部变量 二级基址, 整数型
.局部变量 三级基址, 整数型
.局部变量 当前血值, 整数型

窗口句柄 = 窗口取句柄 (“Game.exe”)
.如果真 (0 ≠ 窗口句柄)
    进程ID = 窗口取进程ID (窗口句柄)
    基址1 = 内存读整数 (进程ID, #血基址)
    一级基址 = 内存读整数 (进程ID, 基址1 + 100)
    二级基址 = 内存读整数 (进程ID, 一级基址 + 340)
    三级基址 = 内存读整数 (进程ID, 二级基址 + 4)
    当前血值 = 内存读整数 (进程ID, 三级基址 + 1748)
    .如果真 (当前血值 ≠ -1 且 当前血值 ≤ 到数值 (编辑框1.内容))
        按键消息 (窗口句柄, #F8键)
    .如果真结束

.如果真结束


.子程序 自动加蓝
.局部变量 窗口句柄, 整数型
.局部变量 进程ID, 整数型
.局部变量 三级基址, 整数型
.局部变量 二级基址, 整数型
.局部变量 一级基址, 整数型
.局部变量 基址1, 整数型
.局部变量 当前蓝值, 整数型

窗口句柄 = 窗口取句柄 (“Game.exe”)
.如果真 (0 ≠ 窗口句柄)
    进程ID = 窗口取进程ID (窗口句柄)
    基址1 = 内存读整数 (进程ID, #蓝基址)
    一级基址 = 内存读整数 (进程ID, 基址1 + 100)
    二级基址 = 内存读整数 (进程ID, 一级基址 + 340)
    三级基址 = 内存读整数 (进程ID, 二级基址 + 4)
    当前蓝值 = 内存读整数 (进程ID, 三级基址 + 1752)
    .如果真 (当前蓝值 ≠ -1 且 当前蓝值 ≤ 到数值 (编辑框2.内容))
        按键消息 (窗口句柄, #F9键)
    .如果真结束

.如果真结束


.子程序 宝宝加血
.局部变量 窗口句柄, 整数型
.局部变量 进程ID, 整数型
.局部变量 一级基址, 整数型
.局部变量 基址1, 整数型
.局部变量 当前BB血值, 整数型

窗口句柄 = 窗口取句柄 (“Game.exe”)
.如果真 (0 ≠ 窗口句柄)
    进程ID = 窗口取进程ID (窗口句柄)
    基址1 = 内存读整数 (进程ID, #宝宝血基址)
    一级基址 = 内存读整数 (进程ID, 基址1 + 286260)
    当前BB血值 = 内存读整数 (进程ID, 一级基址 + 60)
    .如果真 (当前BB血值 ≠ -1 且 当前BB血值 ≤ 到数值 (编辑框3.内容))
        按键消息 (窗口句柄, #F10键)
    .如果真结束

.如果真结束


.子程序 _按钮1_被单击
.局部变量 进程ID, 整数型
.局部变量 窗口句柄, 整数型

窗口句柄 = 窗口取句柄 (“Game.exe”)
.如果真 (0 ≠ 窗口句柄)
    进程ID = 窗口取进程ID (窗口句柄)
    自动选怪 ()
.如果真结束


.子程序 _按钮2_被单击
.局部变量 窗口句柄, 整数型
.局部变量 进程ID, 整数型

窗口句柄 = 窗口取句柄 (“Game.exe”)
.如果真 (0 ≠ 窗口句柄)
    进程ID = 窗口取进程ID (窗口句柄)
    按键消息 (窗口句柄, #F1键)
.如果真结束


.子程序 _按钮4_被单击
.局部变量 进程ID, 整数型
.局部变量 窗口句柄, 整数型

窗口句柄 = 窗口取句柄 (“Game.exe”)
.如果真 (0 ≠ 窗口句柄)
    进程ID = 窗口取进程ID (窗口句柄)
    宝宝加血 ()
.如果真结束


.子程序 _时钟1加血_周期事件

.如果真 (选择框1.选中)
    自动加血 ()
.如果真结束


.子程序 _时钟2加蓝_周期事件

.如果真 (选择框1.选中)
    自动加蓝 ()
.如果真结束


.子程序 _时钟3加BB血_周期事件

.如果真 (选择框2.选中)
    宝宝加血 ()
.如果真结束


.子程序 _时钟4_周期事件
.局部变量 进程ID, 整数型
.局部变量 窗口句柄, 整数型

窗口句柄 = 窗口取句柄 (“Game.exe”)
.如果真 (0 ≠ 窗口句柄)
    进程ID = 窗口取进程ID (窗口句柄)
    .如果 (取颜色 (窗口句柄, 272, 1) = 8102589)
        _按钮2_被单击 ()
    .否则
        _按钮1_被单击 ()
    .如果结束
    .如果 (取颜色 (窗口句柄, 247, 29) = 526352)
        _按钮1_被单击 ()
    .否则
        _按钮2_被单击 ()
    .如果结束

.如果真结束


.子程序 _时钟6捡东西_周期事件
.局部变量 进程ID, 整数型
.局部变量 窗口句柄, 整数型

窗口句柄 = 窗口取句柄 (“Game.exe”)
.如果真 (0 ≠ 窗口句柄)
    进程ID = 窗口取进程ID (窗口句柄)
    自动捡物品 ()
.如果真结束


.子程序 自动捡物品
.局部变量 进程ID, 整数型
.局部变量 窗口句柄, 整数型
.局部变量 坐标, 识图_坐标, 静态

窗口句柄 = 窗口取句柄 (“Game.exe”)
.如果真 (0 ≠ 窗口句柄)
    进程ID = 窗口取进程ID (窗口句柄)
    坐标 = 屏幕_找图 (#物品图, , , , , , 坐标, 窗口句柄)
    识图_移到坐标 (坐标, 窗口句柄)
    按键消息 (窗口句柄, #左键_, , )
.如果真结束


.子程序 自动选择
.局部变量 时限, 整数型

.如果真 (选择框1.选中)
    时钟1加血.时钟周期 = 300
.如果真结束
.如果真 (选择框2.选中)
    时钟2加蓝.时钟周期 = 300
.如果真结束
.如果真 (选择框3.选中)
    时钟3加BB血.时钟周期 = 300
.如果真结束
.如果真 (选择框4.选中)
    时钟4.时钟周期 = 100
.如果真结束
.如果真 (选择框5.选中)
    时钟5技能打怪.时钟周期 = 100
.如果真结束
.如果真 (选择框6.选中)
    时钟6捡东西.时钟周期 = 0
.如果真结束
.如果真 (选择框8.选中)
    时限 = 到整数 (编辑框5.内容)
    时钟8选怪.时钟周期 = 时限 × 1000
.如果真结束
按钮8.禁止 = 假
按钮7.禁止 = 真
按钮5.禁止 = 真

.子程序 停止选择

时钟1加血.时钟周期 = 0
时钟2加蓝.时钟周期 = 0
时钟3加BB血.时钟周期 = 0
时钟4.时钟周期 = 0
时钟5技能打怪.时钟周期 = 0
时钟6捡东西.时钟周期 = 0
时钟8选怪.时钟周期 = 0
按钮7.禁止 = 假
按钮8.禁止 = 真
按钮5.禁止 = 假

.子程序 _按钮6_被单击

写配置项 (配置文件, “设定”, “人物血量”, 编辑框1.内容)
写配置项 (配置文件, “设定”, “人物蓝量”, 编辑框2.内容)
写配置项 (配置文件, “设定”, “宝宝血量”, 编辑框3.内容)
写配置项 (配置文件, “设定”, “打怪时限”, 编辑框5.内容)
信息框 (“保存成功!”, 0, “提示”)

.子程序 _按钮5_被单击

撤销所有热键 ()
结束 ()

.子程序 _时钟5技能打怪_周期事件
.局部变量 进程ID, 整数型
.局部变量 窗口句柄, 整数型

窗口句柄 = 窗口取句柄 (“Game.exe”)
.如果真 (0 ≠ 窗口句柄)
    进程ID = 窗口取进程ID (窗口句柄)
    .如果真 (选择框5.选中)
        时钟4.时钟周期 = 0
        .如果 (取颜色 (窗口句柄, 272, 1) = 8102589)
            _按钮2_被单击 ()
        .否则
            _按钮1_被单击 ()
        .如果结束
        .如果 (取颜色 (窗口句柄, 247, 29) = 526352)
            _按钮1_被单击 ()
        .否则
            _按钮2_被单击 ()
        .如果结束
        按键消息 (窗口句柄, #F1键)
        按键消息 (窗口句柄, #F2键)
        按键消息 (窗口句柄, #F3键)
        按键消息 (窗口句柄, #F4键)
        按键消息 (窗口句柄, #F5键)
        按键消息 (窗口句柄, #F6键)
        按键消息 (窗口句柄, #F7键)
    .如果真结束

.如果真结束


.子程序 _按钮7_被单击

按钮8.禁止 = 假
按钮7.禁止 = 真
按钮5.禁止 = 真
自动选择 ()

.子程序 _按钮8_被单击

停止选择 ()
按钮7.禁止 = 假
按钮8.禁止 = 真
按钮5.禁止 = 假

.子程序 _时钟8选怪_周期事件
.局部变量 进程ID, 整数型
.局部变量 窗口句柄, 整数型

窗口句柄 = 窗口取句柄 (“Game.exe”)
.如果真 (0 ≠ 窗口句柄)
    进程ID = 窗口取进程ID (窗口句柄)
    .如果真 (选择框8.选中)
        自动选怪 ()
    .如果真结束

.如果真结束


http://yunpan.cn/QX2LrbXLYT7na
附件: 天龙八部自动打怪.7z (149 K) 下载次数:23
善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
离线l942023981

只看该作者 沙发  发表于: 2016-01-25
看看,,,,,,,,,,,,

只看该作者 板凳  发表于: 2016-03-21
感谢楼主分享!!!!
离线mxx12345

只看该作者 地板  发表于: 02-03
感谢楼主分享!
快速回复
限100 字节
如果您在写长篇帖子又不马上发表,建议存为草稿
 
上一个 下一个