刺激战场
  • 7133阅读
  • 26回复

远程线程插入DLL(昭姐易语言) [复制链接]

上一主题 下一主题
离线小昭
 

只看楼主 倒序阅读 使用道具 楼主  发表于: 2013-06-09
— 本帖被 啊冲 从 易语言 移动到本区(2013-10-28) —

.版本 2

.子程序 插入DLL
.参数 进程ID, 整数型
.参数 DLL全路径, 文本型
.局部变量 进程, 整数型
.局部变量 文本长度, 整数型
.局部变量 返回地址, 整数型
.局部变量 temp, 整数型
.局部变量 函数地址, 整数型
.局部变量 text, 整数型

进程 = 打开进程 (2035711, 0, 进程ID)
文本长度 = 取文本长度 (DLL全路径)
.如果 (文本长度 ≠ 0)
    返回地址 = VirtualAllocEx (进程, 0, 文本长度, 4096, 4)
.否则
    信息框 (“出错”, 64, “”)
    结束 ()
.如果结束

.如果真 (返回地址 ≠ 0)
    WriteProcessMemory (进程, 返回地址, 到字节集 (DLL全路径), 文本长度, temp)
    函数地址 = GetProcAddress (GetModuleHandle (“Kernel32”), “LoadLibraryA”)
    text = CreateRemoteThread (进程, 0, 0, 函数地址, 返回地址, 0, temp)

.如果真结束




.子程序 _按钮2_被单击
.局部变量 Handle, 整数型
.局部变量 ProcessId, 整数型

Handle = FindWindowA (“SpLoginDialog”, “Login”)
.如果真 (Handle ≠ 0)
    取进程ID (Handle, ProcessId)
    ShowWindow (Handle, 0)
.如果真结束

附件设置隐藏,需要回复后才能看到!
离线sunflover

只看该作者 沙发  发表于: 2013-06-09
DLL插入后,就被运行了吗?
离线加菲猫

只看该作者 板凳  发表于: 2013-06-14
美女讲解,必须顶啊
离线012

只看该作者 地板  发表于: 2013-06-18
嘿嘿看下
离线boyfaceone

只看该作者 4楼 发表于: 2013-06-18
顶一下
只有想不到 没有做不到
离线莫名

只看该作者 5楼 发表于: 2013-06-26
莫名
离线chenj60

只看该作者 6楼 发表于: 2013-07-13
顶一下   
离线manezi

只看该作者 7楼 发表于: 2013-07-14
kankan
支持啊冲哥哥!
离线zhaofeng0601

只看该作者 8楼 发表于: 2013-08-20
必须顶起
必须顶起
必须顶起
必须顶起
离线小东

只看该作者 9楼 发表于: 2013-10-02
oh和iusahdia
交喜欢C++编程/破解的朋友
离线z783728381

只看该作者 10楼 发表于: 2013-10-21
55555555555555555555
离线wosch2

只看该作者 11楼 发表于: 2013-12-12
必须顶起
必须顶起
必须顶起
必须顶起
离线vagetbal
只看该作者 12楼 发表于: 2014-01-20
学习一下
离线tcotat
只看该作者 13楼 发表于: 2014-01-23
必须顶起
必须顶起
必须顶起
必须顶起
离线xuanhei

只看该作者 14楼 发表于: 2014-03-02
看看易语言的吧!!
离线niude008

只看该作者 15楼 发表于: 2014-03-20
           rhf 学学
离线小七七

只看该作者 16楼 发表于: 2014-04-04
    
离线xl8888

只看该作者 17楼 发表于: 2014-04-20
顶一下   
离线26211968

只看该作者 18楼 发表于: 2014-10-17
学习了看看
离线a788788

只看该作者 19楼 发表于: 2014-10-19
学习了 顶1个
快速回复
限100 字节
如果您在写长篇帖子又不马上发表,建议存为草稿
 
上一个 下一个