• 2587阅读
  • 5回复

易语言辅助--任务逻辑 无卡点(QQ仙侠实例) [复制链接]

上一主题 下一主题
离线任鸟飞
 

只看楼主 倒序阅读 使用道具 楼主  发表于: 2014-10-17
— 本帖被 啊冲 执行取消置顶操作(2016-12-14) —

.版本 2

.如果真 (取人物等级 () < 2)
    .循环判断首 ()
        .如果真 (取当前地图 () = “穹苍”)
            .循环判断首 ()
                寻路 (135, 90, “”)
                打开NPC (“慕容慕容”)
                NPC选项 (0)
                NPC选项 (0)
                NPC选项 (0)
                超级延时 (4000)
            .循环判断尾 (取当前地图 () = “穹苍”)
        .如果真结束
        寻路 (252, 881, “”)
        打开NPC (“轩辕龙羿”)
        NPC选项 (0)
        NPC选项 (0)
        NPC选项 (0)
    .循环判断尾 (取人物等级 () = 1)
.如果真结束
.如果真 (是否有该可接任务 (“星界之秘”) = 1)
    .循环判断首 ()
        寻路 (252, 881, “”)
        打开NPC (“轩辕龙羿”)
        NPC选项 (0)
        NPC选项 (0)
        NPC选项 (0)
    .循环判断尾 (是否有该已接任务 (“星界之秘”) = 0)
    ' ''''''''''''''''''''''''''''''''''''''''''''''''''''''接任务 星界之秘
.如果真结束
.如果真 (是否有该已接任务 (“星界之秘”) = 1)
    .循环判断首 ()
        寻路 (241, 774, “”)
        打开NPC (“堕天”)
        NPC选项 (0)
        NPC选项 (0)
        NPC选项 (0)
        ' ''''''''''''''''''''''''''''''''''''''''交任务 星界之秘#######
    .循环判断尾 (是否有该已接任务 (“星界之秘”) = 1)
.如果真结束
.如果真 (是否有该可接任务 (“初识仙尊”) = 1)
    .循环判断首 ()
        寻路 (241, 774, “”)
        打开NPC (“堕天”)
        NPC选项 (0)
        NPC选项 (0)
        NPC选项 (0)
    .循环判断尾 (是否有该已接任务 (“初识仙尊”) = 0)
    ' ''''''''''''''''''''''''''''''''''''''''''''''''''''''接任务 初识仙尊
1条评分小风币+5
啊冲 小风币 +5 感谢分享 2014-10-17
离线啊冲

只看该作者 沙发  发表于: 2014-10-17
感谢分享
离线121770101

只看该作者 板凳  发表于: 2014-10-26
这个还真不好搞!
离线lukeigun

只看该作者 地板  发表于: 2015-01-05
感谢分享
离线y000op

只看该作者 4楼 发表于: 2015-05-15
支持一下!
离线haocheng

只看该作者 5楼 发表于: 2015-05-20
看不懂啊。。。
快速回复
限100 字节
批量上传需要先选择文件,再选择上传
 
上一个 下一个