• 953阅读
  • 2回复

乐易贵宾教程QQ空间-百度系列POST教程 2、百度登录[代码实现] [复制链接]

上一主题 下一主题
离线啊冲
 

只看楼主 倒序阅读 使用道具 楼主  发表于: 2016-08-26

.版本 2
.支持库 spec

.程序集 窗口程序集_启动窗口
.程序集变量 Cookies, 文本型

.子程序 __启动窗口_创建完毕

' 第一步 获取token标志


.子程序 GetToken, 文本型, , Token标志的网址
.局部变量 局部_返回文本, 文本型

局部_返回文本 = 到文本 (网页_访问 (“http://passport.baidu.com/v2/api/?getapi&class=login&tpl=mn&tangram=true”))
局部_返回文本 = 文本_取出中间文本 (局部_返回文本, #常量_token1, #常量_token2)
返回 (局部_返回文本)


.子程序 无码登录百度贴吧, 文本型, , ,
.参数 帐号, 文本型
.参数 密码, 文本型
.局部变量 提交地址, 文本型
.局部变量 提交数据, 文本型
.局部变量 返回值, 文本型

提交地址 = “https://passport.baidu.com/v2/api/?login
提交数据 = “ppui_logintime=” + 文本_取随机数字 (5) + “&charset=utf-8&codestring=&token=” + GetToken () + “&isPhone=false&index=0&u=&safeflg=0&staticpage=http%3A%2F%2Fwww.baidu.com%2Fcache%2Fuser%2Fhtml%2Fjump.html&loginType=1&tpl=mn&callback=parent.bdPass.api.login._postCallback&username=” + 编码_URL编码 (帐号, 真, 真) + “&password=” + 密码 + “&verifycode=&mem_pass=o”
返回值 = 到文本 (网页_访问 (提交地址, 1, 提交数据, , Cookies, , , , , , ))
调试输出 (返回值)
.如果真 (寻找文本 (返回值, “error=0”, , 假) ≠ -1)
    返回 (Cookies)
.如果真结束
.如果真 (寻找文本 (返回值, “error=4”, , 假) ≠ -1)
    返回 (“用户名或者密码错误!”)
.如果真结束
.如果真 (寻找文本 (返回值, “error=257=4”, , 假) ≠ -1)
    返回 (“请检测是否需要验证码!”)
.如果真结束
返回 (“未知错误!”)

.子程序 _按钮1_被单击

信息框 (无码登录百度贴吧 (编辑框1.内容, 编辑框2.内容), 0, , )
善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
离线yuyou

只看该作者 沙发  发表于: 2017-08-08
离线aandok

只看该作者 板凳  发表于: 02-18

0012F2BC   00455694  |Title = "信?,A2,""
0012F2C0   00000000  \Style
快速回复
限100 字节
如果您在写长篇帖子又不马上发表,建议存为草稿
 
上一个 下一个