刺激战场
  • 1095阅读
  • 1回复

乐易贵宾教程QQ空间-百度系列POST教程 13、上传头像[抓包分析] [复制链接]

上一主题 下一主题
离线啊冲
 

只看楼主 倒序阅读 使用道具 楼主  发表于: 2016-08-26
.版本 2
.支持库 spec

.程序集 程序集_更改头像

.子程序 更换头像
.参数 头像图片, 字节集
.局部变量 portrait, 文本型
.局部变量 网页源文件, 文本型
.局部变量 bdstoken, 文本型
.局部变量 局部_提交地址, 文本型
.局部变量 DATA, 字节集
.局部变量 PICID, 文本型

网页源文件 = 到文本 (网页_访问 (“http://www.baidu.com/p/setting/profile/portrait”, , , Cookies))
portrait = 文本_取出中间文本 (网页源文件, #常量_portrait1, “',”)
bdstoken = 文本_取出中间文本 (网页源文件, #常量_bdstoken1, #引号)
局部_提交地址 = “http://himg.baidu.com/sys/preview/” + portrait
DATA = 到字节集 (#常量_图片数据)
DATA = 子字节集替换 (DATA, 到字节集 (“[bdstoken]”), 到字节集 (bdstoken), , )
DATA = 子字节集替换 (DATA, 到字节集 (“[psign]”), 到字节集 (portrait), , )
DATA = 子字节集替换 (DATA, 到字节集 (“[pic]”), 头像图片, , )
网页源文件 = 到文本 (网页_访问_对象 (局部_提交地址, 1, , Cookies, , #常量_网页协议 + #换行符, , , DATA, , ))
PICID = 文本_取出中间文本 (网页源文件, “&picId=”, #引号)
网页源文件 = 编码_usc2到ansi (网页_访问s (“http://himg.baidu.com/sys/corpupload?callback=jQuery190028958377972534527_1430292671951&coordX=0&coordY=0&coordW=200&coordH=200&psign=” + portrait + “&picId=” + PICID + “&bdstoken=” + bdstoken + “&_=” + 时间_取现行时间戳 (), , , Cookies))
调试输出 (网页源文件)
网页源文件 = 网页_访问u (“http://himg.baidu.com/sys/history?callback=jQuery190028958377972534527_143029267195&bdstoken=” + bdstoken + “&psign=” + portrait + “&length=3&prefix=princess&staticpage=http%3A%2F%2Fwww.baidu.com%2Fp%2Fjump.html&_=” + 时间_取现行时间戳 (), , , Cookies)
调试输出 (网页源文件)
善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
离线lk0607

只看该作者 沙发  发表于: 05-19
真的很好 谢谢大哥分享!8
快速回复
限100 字节
批量上传需要先选择文件,再选择上传
 
上一个 下一个