• 966阅读
  • 0回复

乐易贵宾教程QQ空间-百度系列POST教程 14、获取贴吧成员 [复制链接]

上一主题 下一主题
离线啊冲
 

只看楼主 倒序阅读 使用道具 楼主  发表于: 2016-08-26
.版本 2
.支持库 iext

.程序集 窗口程序集_启动窗口
.程序集变量 o

.子程序 __启动窗口_创建完毕



.子程序 正则_匹配批量, 整数型, , 本子程序采用【精易编程助手】生成。成功返回匹配的数量,失败返回0。
.参数 源文本, 文本型, , 欲被匹配的文本
.局部变量 局_正则, 类_正则表达式, , , 此类为精易模块里面的正则类,精易模块下载地址:www.3600gz.cn/thread-1177-1-1.html
.局部变量 局_匹配数, 整数型
.局部变量 局_计次, 整数型
.局部变量 temp, 整数型

.如果真 (局_正则.创建 (“username=#引号(.*?)#引号”, 源文本, 假, 假, 真, 真) = 假)
    信息框 (“正则创建失败,请检查正则表达式语句是否有误!”, #错误图标, , )
    返回 (0)
.如果真结束
局_匹配数 = 局_正则.取匹配数量 ()
.如果真 (局_匹配数 = 0)
    信息框 (“匹配失败,请检检查正则语句是否有误,数量:0”, #错误图标, , )
    返回 (0)
.如果真结束
.计次循环首 (局_匹配数, 局_计次)
    temp = 超级列表框1.插入表项 (, 到文本 (o + 1), , , , )
    超级列表框1.置标题 (temp, 1, “@” + 编码_URL解码 (局_正则.取子匹配文本 (局_计次, 1)) + “”)
    o = o + 1
    处理事件_ ()
.计次循环尾 ()
返回 (局_匹配数)




.子程序 _按钮1_被单击

线程_启动 (&子程序1)




.子程序 子程序1
.局部变量 i, 整数型



.计次循环首 (100, i)
    正则_匹配批量 (网页_访问u (“http://tieba.baidu.com/f/like/furank?kw=%D2%D7%D3%EF%D1%D4&pn=” + 到文本 (i)))
.计次循环尾 ()


善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
快速回复
限100 字节
如果您在写长篇帖子又不马上发表,建议存为草稿
 
上一个 下一个