• 942阅读
  • 1回复

乐易贵宾教程QQ空间-百度系列POST教程 18、取百度好友(抓包分析+代码讲解) [复制链接]

上一主题 下一主题
离线啊冲
 

只看楼主 倒序阅读 使用道具 楼主  发表于: 2016-08-26
18、取百度好友(抓包分析+代码讲解)

学习心得:不要看着简单就不去做,只是看看的话,你还是什么都不会!

提交地址

http://tieba.baidu.com/im/pcmsg/query/getFriends?noCache=1437062904532&offset=10

提交数据

cuid=1256325B4521C1D3AC235C05A3A67133%3AFG%3D1

cuid=1256325B4521C1D3AC235C05A3A67133:FG=1

Cuid:$.cookie("BAIDUID")

BAIDUID=1256325B4521C1D3AC235C05A3A67133:FG=1;

URL编码(GBK): 1256325B4521C1D3AC235C05A3A67133%3AFG%3D1

{"uid":"(.*?)","uname":"(.*?)","name_show":"(.*?)","portrait":"(.*?)","gender":"(.*?)"
善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
离线啊冲

只看该作者 沙发  发表于: 2016-08-26
.版本 2
.支持库 iext

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕



.子程序 正则_匹配批量, 整数型, , 本子程序采用【精易编程助手】生成。成功返回匹配的数量,失败返回0。
.参数 源文本, 文本型, , 欲被匹配的文本
.局部变量 局_正则, 类_正则表达式, , , 此类为精易模块里面的正则类,精易模块下载地址:www.3600gz.cn/thread-1177-1-1.html
.局部变量 局_匹配数, 整数型
.局部变量 局_计次, 整数型
.局部变量 UID, 文本型
.局部变量 Name, 文本型
.局部变量 p, 文本型
.局部变量 BX, 整数型
.局部变量 Sex, 文本型

.如果真 (局_正则.创建 (“{#引号uid#引号:#引号(.*?)#引号,#引号uname#引号:#引号(.*?)#引号,#引号name_show#引号:#引号(.*?)#引号,#引号portrait#引号:#引号(.*?)#引号,#引号gender#引号:#引号(.*?)#引号”, 源文本, 假, 真, 真, 真) = 假)
    信息框 (“正则创建失败,请检查正则表达式语句是否有误!”, #错误图标, , )
    返回 (0)
.如果真结束
局_匹配数 = 局_正则.取匹配数量 ()
.如果真 (局_匹配数 = 0)
    信息框 (“匹配失败,请检检查正则语句是否有误,数量:0”, #错误图标, , )
    返回 (0)
.如果真结束
.计次循环首 (局_匹配数, 局_计次)
    UID = 局_正则.取子匹配文本 (局_计次, 1)
    Name = 局_正则.取子匹配文本 (局_计次, 2)
    p = 局_正则.取子匹配文本 (局_计次, 4)
    Sex = 局_正则.取子匹配文本 (局_计次, 5)
    BX = 超级列表框1.插入表项 (, UID, , , , )

    超级列表框1.置标题 (BX, 1, Name)
    超级列表框1.置标题 (BX, 2, p)
    .如果真 (Sex = “1”)
        超级列表框1.置标题 (BX, 3, “男”)
    .如果真结束
    .如果真 (Sex = “2”)
        超级列表框1.置标题 (BX, 3, “女”)
    .如果真结束
    .如果真 (Sex = “0”)
        超级列表框1.置标题 (BX, 3, “未知”)
    .如果真结束

.计次循环尾 ()
返回 (局_匹配数)

.子程序 _按钮1_被单击
.局部变量 i, 整数型
.局部变量 cuid, 文本型


cuid = 文本_取出中间文本 (Cookies, “BAIDUID=”, “;”)
.计次循环首 (10, i)
    处理事件_ ()
    正则_匹配批量 (编码_usc2到ansi (网页_访问u (“http://tieba.baidu.com/im/pcmsg/query/getFriends?noCache=” + 时间_取现行时间戳 () + “&offset=” + 到文本 (i × 10), 1, “cuid=” + 编码_URL编码 (cuid), Cookies, , , , )))
.计次循环尾 ()

善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
快速回复
限100 字节
如果您在写长篇帖子又不马上发表,建议存为草稿
 
上一个 下一个