• 1041阅读
  • 9回复

任鸟飞 第3期 下部 笔记 [复制链接]

上一主题 下一主题
离线啊冲
 

只看楼主 倒序阅读 使用道具 楼主  发表于: 2016-08-27
任鸟飞2014 辅助培训班
外部群:239774259
第3期第1课
1. 3-4节  第2期的总结
2. 1星期 来把QQ仙侠传
3. 1星期   一些其他的开始没太深入了解的技巧
4. 2星期到3星期   新游戏
5.黑屏优化  多开 隐藏模块  隐藏EXE  主线程调用 等等一些小技巧

CALL的基本结构
分析EBP  ESP

PUSH EAX
PUSH ESI
CALL xxxxxxxx

push ebp
mov ebp,esp
sub esp,8

ESP     。。。   第二个局部变量
        。。。   第一个局部变量
EBP        EBP(上一层CALL的EBP)
           call执行结束以后返回的代码执行位置
           esi   第一个参数
           eax   第二个参数


善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
离线啊冲

只看该作者 沙发  发表于: 2016-08-27
血地址
009E015E - F3 0F2A 00  - cvtsi2ss xmm0,[eax]
00934D43 - F3 0F2A 00  - cvtsi2ss xmm0,[eax]
0090E0DF - 8B 00  - mov eax,[eax]
0090E05F - 89 41 04  - mov [ecx+04],eax
0098821A - F3 0F2A 00  - cvtsi2ss xmm0,[eax]
0094329B - 8B 00  - mov eax,[eax]
0093A9DA - F3 0F2A 00  - cvtsi2ss xmm0,[eax]
008B31EC - F3 0F2A 00  - cvtsi2ss xmm0,[eax]
008B32AC - 3B 08  - cmp ecx,[eax]
008B3303 - 8B 10  - mov edx,[eax]
008B333D - 8B 08  - mov ecx,[eax]
008B737C - F3 0F2A 00  - cvtsi2ss xmm0,[eax]
008B7403 - 3B 10  - cmp edx,[eax]
008B745E - 8B 00  - mov eax,[eax]
0090AAB4 - 89 41 04  - mov [ecx+04],eax


16B986D4

dd [11FD7A4]+160C


dd [[[[11FCB40]+394]+15ec]+15ec]+160C


dd [[11FCB40]+394]+160C
善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
离线啊冲

只看该作者 板凳  发表于: 2016-08-27
任鸟飞2014  辅助培训班
第3期第4课
QQ:313866957


数据结构复习

数组         [ebx+eax*4]
imul    eax,eax,4      eax*4+ebx
add     eax,ebx   eax==eax+ebx


二叉树  


链表
[[[基地址]+偏移1]+15EC]+160c

+15EC  这个地方  发现类似于循环的代码



找CALL 复习

ecx,ebx     ecx 往往是这个  人物对象 或则一些什么关键的东西
善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
离线啊冲

只看该作者 地板  发表于: 2016-08-27
任鸟飞2014  辅助培训班
第3期第5课
QQ:313866957

数据:
人物    血量 蓝量  等级  所在地图  坐标值
所有怪物/npc/玩家     血量  等级 坐标值 是否是BOSS   ID  
背包物品     位置  数量  id
技能      ID  等级  冷却时间
地面物品    ID  坐标值
任务      ID  完成状态  打怪数量 (难度稍大)
拍卖行  一些其他的日常任务

CALL:
登录CALL (按键或则控件)
角色数量---------判断创建的情况
角色对象---------没有入游戏画面 0       进入游戏画面他有值
创建角色CALL
进入游戏CALL
小退CALL

技能CALL
吃药CALL
穿装备CALL
寻路CALL
选怪CALL
买卖CALL
打开NPC CALL
NPC 选项CALL
提交任务CALL
接任务CALL

捡取物品CALL
上马CALL


逻辑:
自动登录
创建角色 换号
自动打怪
自动任务
...
...
...


多开:

测试:

加壳 vmp 网络验证:

善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
离线啊冲

只看该作者 4楼 发表于: 2016-08-27
任鸟飞2014  辅助培训班
第3期第6课
QQ:313866957
仙侠传 任务数组
{
名称
打怪数量
ID
任务完成状态
}
接任务CALL
放弃任务CALL
---------------------访问任务ID

去找一下放弃任务CALL



调用堆栈:     主线程
地址       堆栈       函数过程                              调用来自                      结构
0012E104   0F632D35   WS2_32.send                           Protocal.0F632D2F
0012E234   0F6324B9   Protocal.0F632C50                     Protocal.0F6324B4
0012E248   0F623A84   Protocal.0F6324A0                     Protocal.0F623A7F             0012E274
0012F2A4   0F5ED8AA   ? Protocal.0F623820                   Protocal.0F5ED8A5             0012E274
0012F2F8   0F5E4ABC   包含Protocal.0F5ED8AA                   Protocal.0F5E4AB9
0012F30C   005BC6FD   包含Protocal.0F5E4ABC                   XXZShell.005BC6FA
0012F344   0057FFE2   包含XXZShell.005BC6FD                   XXZShell.0057FFDF
0012F358   0050141E   XXZShell.0057FFC0                     XXZShell.00501419


00501418    52              push    edx                              ; edx 就是任务ID
00501419    E8 A2EB0700     call    0057FFC0                         ; 1
0050141E    83C4 04         add     esp, 4

放弃任务CALL



[[0BA9310]+8]+0*3B8+24  任务的名称
[[0BA9310]+8]+0*3B8+0    任务的ID
任务的完成状态
任务的打怪数量


就可以用来判断   我们身上有什么任务了( 任务的完成状态)




善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
离线啊冲

只看该作者 5楼 发表于: 2016-08-27
任鸟飞2014  辅助培训班
第3期第7课
QQ:313866957
仙侠传 任务数组(可接)
接任务CALL

调用堆栈:     主线程
地址       堆栈       函数过程                              调用来自                      结构
0012E104   0F632D35   WS2_32.send                           Protocal.0F632D2F
0012E234   0F6324B9   Protocal.0F632C50                     Protocal.0F6324B4
0012E248   0F623A84   Protocal.0F6324A0                     Protocal.0F623A7F             0012E274
0012F2A4   0F5ED8AA   ? Protocal.0F623820                   Protocal.0F5ED8A5             0012E274
0012F2F8   0F5E4ABC   包含Protocal.0F5ED8AA                   Protocal.0F5E4AB9
0012F30C   005BC4DC   包含Protocal.0F5E4ABC                   XXZShell.005BC4D9
0012F344   00527E94   包含XXZShell.005BC4DC                   XXZShell.00527E91
0012F35C   00528286   包含XXZShell.00527E94                   XXZShell.00528283
0012F36C   00E2C940   包含XXZShell.00528286                   XXZShell.00E2C93D

调用堆栈:     主线程
地址       堆栈       函数过程                              调用来自                      结构
0012E10C   0F632D35   WS2_32.send                           Protocal.0F632D2F
0012E23C   0F6324B9   Protocal.0F632C50                     Protocal.0F6324B4
0012E250   0F623A84   Protocal.0F6324A0                     Protocal.0F623A7F             0012E27C
0012F2AC   0F5ED8AA   ? Protocal.0F623820                   Protocal.0F5ED8A5             0012E27C
0012F300   0F5E4ABC   包含Protocal.0F5ED8AA                   Protocal.0F5E4AB9
0012F314   005BC6FD   包含Protocal.0F5E4ABC                   XXZShell.005BC6FA
0012F34C   005BE51E   XXZShell.005BC310                     XXZShell.005BE519
0012F36C   00E70FBC   包含XXZShell.005BE51E                   XXZShell.00E70FB9


通过放弃任务CALL  找到这个任务的任务ID

在任务ID 上下写入断点

再去接任务的时候   会断下  断到的位置  其实就是接任务CALL  或则说是 断到可接任务的数组的地方


EDX+eax*3B8  eax==0   15e0e0f8

00501E80 - 8B 41 28  - mov eax,[ecx+28]
00501EA5 - 8B 41 28  - mov eax,[ecx+28]
007B8442 - 8B 00  - mov eax,[eax]
007C9686 - 8B 00  - mov eax,[eax]

[[00BA9310]+28]+0*3B8
可接任务数组
+24名称


找到 任务打怪数量  和任务的完成状态
然后来讲解一下   自动任务的写法 逻辑方面

善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
离线啊冲

只看该作者 6楼 发表于: 2016-08-27
任鸟飞2014  辅助培训班
第3期第8课
QQ:313866957
仙侠传任务逻辑

已接任务数组
[[00BA9310]+8]+0*3B8    ID      [[00BA9310]+8]+1*3B8    ID
[[00BA9310]+8]+0*3B8+24 名称
[[00BA9310]+8]+0*3B8+12c  打怪数量
[[00BA9310]+8]+0*3B8+3a5  完成状态
可接任务数组
[[00BA9310]+28]+0*3B8    ID
[[00BA9310]+28]+0*3B8+24 名称 =""

任务的完成状态
任务的打怪数量




.版本 2

.如果真 (是否有该可接任务 (“星界之秘”) = 1)

    .循环判断首 ()

        寻路 (252, 881, “”)
        打开NPC (“轩辕龙羿”)
        NPC选项 (0)
        NPC选项 (0)
        NPC选项 (0)

    .循环判断尾 (是否有该已接任务 (“星界之秘”) = 0)
    ' ''''''''''''''''''''''''''''''''''''''''''''''''''''''接任务 星界之秘
.如果真结束
.如果真 (是否有该已接任务 (“星界之秘”) = 1)

    .循环判断首 ()

        寻路 (241, 774, “”)
        打开NPC (“堕天”)
        NPC选项 (0)
        NPC选项 (0)
        NPC选项 (0)
        ' ''''''''''''''''''''''''''''''''''''''''交任务 星界之秘#######
    .循环判断尾 (是否有该已接任务 (“星界之秘”) = 1)


.版本 2

.如果真 (是否有该已接任务 (“消灭莲魂镜影”) = 1)

    .如果真 (任务是否完成 (“消灭莲魂镜影”) = 0)

        .循环判断首 ()
            寻路 (246, 670, “”)
            自动打怪 (1, “莲魂镜影”)
            ' ''''''''''''''''''''''''''''''''''''''''做任务 消灭莲魂镜影######
        .循环判断尾 (任务是否完成 (“消灭莲魂镜影”) = 0)

    .如果真结束
善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
离线啊冲

只看该作者 7楼 发表于: 2016-08-27
任鸟飞2014  辅助培训班
第3期第10课
QQ:313866957
1-4
5-9
10-14  
15-30  新游戏(逻辑和代码的东西   代码的例子)
3D 转向的问题
1.自己的坐标值
2.怪物的坐标值
3.自己的朝向


1/ 自己和怪物的距离= x1/ X2-X

1/ 自己和怪物的距离= y1/ y2-y

x1,y1
善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
离线啊冲

只看该作者 8楼 发表于: 2016-08-27
任鸟飞2014  辅助培训班
第3期第12课
QQ:313866957

Dd [[[[[21A75A8]+48C]+4]+4]+8]
+EDX*4
+b0 位置是血量


dd [[[[[[[21A75A8]+48C]+4]+4]+8] +edx*4]+8]+0B0
善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
离线啊冲

只看该作者 9楼 发表于: 2016-08-27
任鸟飞2014  辅助培训班
第3期第13课
QQ:313866957

加速

主线程调用

产生数据冲突  导致游戏崩溃

消息子类化()

善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
快速回复
限100 字节
如果您提交过一次失败了,可以用”恢复数据”来恢复帖子内容
 
上一个 下一个