• 963阅读
  • 1回复

编血鬼!加密浮点参数寻路CALL最新Asm汇编功能编写。 [复制链接]

上一主题 下一主题
离线啊冲
 

只看楼主 倒序阅读 使用道具 楼主  发表于: 2016-08-27
----------------
魔鬼作坊
游戏“禁技巧”分析技术揭秘中……
VIP会员办理唯一QQ:8643245
VIP究极模块办理唯一QQ:7189694
----------------
屏幕 1024*768  系统:XP3
编血鬼!加密浮点参数寻路CALL最新汇编功能编写。
魔恩QQ:8643245
各位亲爱的朋友:
我们又在VIP课程相会了,那么,这节课,我将与你分享加密浮点参数寻路CALL最新汇编功能编写。
本课思路:编写的话你只要编写一次,以后都这么编写,一个CALL是这样,其他的CALL也都类似的,延伸过去即可。
具体编写技巧


借鉴:VIP绝密教程:死魂一击!一网游找寻路CALL以及分析加密浮点参数。



push 0x00000001
push 0x00000000
push 0x00000000
push 0x45ff0000
push 0x46174000
mov ecx, dword ptr [0x0128ffc4]
mov ecx, dword ptr [ecx+0x0000041c]
mov ebx, 0x0042f2c0
call ebx
ret
善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
离线啊冲

只看该作者 沙发  发表于: 2016-08-27
.版本 2

.程序集 窗口程序集1
.程序集变量 进程句柄, 整数型

.子程序 __启动窗口_创建完毕

进程句柄 = 进程_取进程句柄 (“client.exe”)
输出调试文本 (进程句柄)

.子程序 _按钮1_被单击, , , ctrl+n

寻路CALL (418, 494)

.子程序 寻路CALL
.参数 X, 小数型
.参数 Y, 小数型
.局部变量 加密X, 小数型
.局部变量 加密Y, 小数型
.局部变量 转换X, 文本型
.局部变量 转换Y, 文本型

加密X = X × 20
加密Y = Y × 20
输出调试文本 (加密X, 加密Y)
转换X = 十到十六 (转换_浮点数转十进制整数 (加密X))
转换Y = 十到十六 (转换_浮点数转十进制整数 (加密Y))
输出调试文本 (转换X, 转换Y)
AsmBegin ()
Asm (“push 1”)
Asm (“push 0”)
Asm (“push 0”)
Asm (“push ” + 转换Y)
Asm (“push ” + 转换X)
Asm (“mov ecx,[” + #ECX基址 + “]”)
Asm (“mov ecx,[ecx+41c]”)
Asm (“mov ebx,” + #寻路CALL)
Asm (“call ebx”)
Asm (“retn”)
AsmCall (进程句柄)  ' DLL用 AsmEnd ()
输出调试文本 (转换_字节集转汇编 (AsmCode ()))

善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
快速回复
限100 字节
如果您提交过一次失败了,可以用”恢复数据”来恢复帖子内容
 
上一个 下一个