• 827阅读
  • 0回复

POST实战演练 第7课:YY商城登陆 [复制链接]

上一主题 下一主题
离线啊冲
 

只看楼主 倒序阅读 使用道具 楼主  发表于: 2016-08-30
.版本 2

.程序集 窗口程序集1
.程序集变量 oauth_token, 文本型

.子程序 _按钮1_被单击

获取数据 ()

.子程序 获取数据
.局部变量 post, 文本型
.局部变量 返回值, 文本型

post = “callbackURL=http%3A%2F%2Fmai.yy.com%2Fs%2Fudbcallback%3Fxparam%3D1&denyCallbackURL=http%3A%2F%2Fmai.yy.com%2Fs%2Fudbcallback%3Fcancel%3D1”
返回值 = 到文本 (E_HTTP_读文本 (“http://mai.yy.com/udblogin”, “POST”, , , post))
oauth_token = 取中间文本KK (返回值, “oauth_token=”, “&denyC”)
编辑框1.内容 = 返回值
标签2.标题 = oauth_token
输出调试文本 (oauth_token)


.子程序 访问登陆成功授权, 文本型
.参数 地址, 文本型
.局部变量 返回值, 文本型

返回值 = E_URL解码_UTF8 (E_HTTP_读文本 (地址))
返回 (返回值)


.子程序 取中间文本KK, 文本型, 公开
.参数 欲取其部分的文本, 文本型
.参数 开始关键字, 文本型
.参数 结束关键字, 文本型
.参数 起始取出位置, 整数型, 可空
.参数 结束字符位置, 整数型, 参考 可空
.局部变量 z1, 整数型
.局部变量 z2, 整数型

.如果真 (是否为空 (起始取出位置))
    起始取出位置 = -1
.如果真结束
z1 = 寻找文本 (欲取其部分的文本, 开始关键字, 起始取出位置, 假)
.如果真 (z1 > -1)
    z1 = z1 + 取文本长度 (开始关键字)
    z2 = 寻找文本 (欲取其部分的文本, 结束关键字, z1, 假)
    .如果真 (z2 > z1)
        结束字符位置 = z2 + 取文本长度 (结束关键字)
        返回 (取文本中间 (欲取其部分的文本, z1, z2 - z1))
    .如果真结束

.如果真结束
结束字符位置 = -1
返回 (“”)

.子程序 yylogin, 文本型
.参数 yyuser, 文本型
.参数 yypass, 文本型
.局部变量 post, 文本型
.局部变量 返回值, 文本型

post = “username=” + yyuser + “&showpwd=%E5%AF%86%E7%A0%81&password=” + yypass + “&oauth_token=” + oauth_token + “&denyCallbackURL=http%3A%2F%2Fmai.yy.com%2Fs%2Fudbcallback%3Fcancel%3D1&securityCode=”
返回值 = E_URL解码_UTF8 (到文本 (E_HTTPS_读文件 (“https://udb.duowan.com/oauth/server/login_x.do”, post)))
输出调试文本 (返回值)
返回 (返回值)

.子程序 _按钮2_被单击

编辑框4.内容 = yylogin (编辑框2.内容, 编辑框3.内容)

.子程序 _按钮3_被单击

编辑框6.内容 = 访问登陆成功授权 (编辑框5.内容)


.子程序 _按钮4_被单击

编辑框8.内容 = E_URL解码_UTF8 (E_HTTP_读文本 (编辑框7.内容))

.子程序 __启动窗口_创建完毕

善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
快速回复
限100 字节
如果您在写长篇帖子又不马上发表,建议存为草稿
 
上一个 下一个