• 830阅读
  • 0回复

POST实战演练 第13课:添加群内成员发送功能,增加计次间隔,增加多内容轮换发送 [复制链接]

上一主题 下一主题
离线啊冲
 

只看楼主 倒序阅读 使用道具 楼主  发表于: 2016-08-30

.版本 2

.程序集 窗口程序集1
.程序集变量 状态, 逻辑型, , , 真为运行
.程序集变量 高度1, 整数型
.程序集变量 宽度1, 整数型
.程序集变量 句柄, 整数型
.程序集变量 总计次, 整数型
.程序集变量 轮流, 整数型

.子程序 _窗口1_将被销毁

结束 ()

.子程序 _开始_被单击

窗口1.位置 = 2
状态 = 真
.如果真 (YY好友.选中)
    YY好友 ()
.如果真结束

.如果真 (YY群成员.选中)
    YY群成员 ()
.如果真结束

.如果真 (YY工会私密.选中)
    YY工会私密 ()
.如果真结束
窗口1.位置 = 1

.子程序 筛选内容, 文本型
.局部变量 分割, 文本型, , "0"

.判断开始 (寻找文本 (发送内容.内容, “~~~~”, , 假) = -1)
    返回 (发送内容.内容)
.默认
    分割 = 分割文本 (发送内容.内容, “~~~~”, )
    轮流 = 轮流 + 1
    .如果真 (轮流 > 取数组成员数 (分割))
        轮流 = 1
    .如果真结束
    返回 (分割 [轮流])
.判断结束


.子程序 等待输入验证码

.判断循环首 (FindWindowA (“QWidget”, “临时会话”) ≠ 0)
    程序_延时 (1000)
.判断循环尾 ()

.子程序 YY好友
.局部变量 临时内容, 文本型
.局部变量 主窗口, 整数型
.局部变量 子内容, 文本型, , "0"
.局部变量 局部计次, 整数型

主窗口 = 进程_名取句柄 (“YY.exe”)
.判断循环首 (状态)
    键盘消息 (主窗口, #下光标键)
    程序_延时 (300)
    键盘消息 (主窗口, #回车键)
    程序_延时 (1000)
    获得好友窗口 ()
    等待输入验证码 ()
    临时内容 = 筛选内容 ()
    .判断开始 (寻找文本 (临时内容, “~”, , 真) = -1)
        文本_投递 (句柄, 临时内容)
        程序_延时 (500)
        鼠标_消息 (句柄, 332, 480)
    .默认
        清除数组 (子内容)
        子内容 = 分割文本 (临时内容, “~”, )
        .计次循环首 (取数组成员数 (子内容), 局部计次)
            等待输入验证码 ()
            文本_投递 (句柄, 子内容 [局部计次])
            程序_延时 (500)
            鼠标_消息 (句柄, 332, 480)
            程序_延时 (1000)
        .计次循环尾 ()
    .判断结束
    总计次 = 总计次 + 1
    程序_延时 (取两者差 (单次频率1, 单次频率2))
    PostMessageA (句柄, 16, 0, 0)
    程序_延时 (200)
    计次延时 ()
.判断循环尾 ()

.子程序 获得好友窗口

句柄 = FindWindowExA (0, 0, “QWidget”, 0)
.判断循环首 (句柄 ≠ 0)
    窗口_取控件大小 (句柄, 宽度1, 高度1)
    .如果真 (高度1 = 500 且 宽度1 = 550)
        跳出循环 ()
    .如果真结束
    句柄 = FindWindowExA (0, 句柄, “QWidget”, 0)
.判断循环尾 ()

.子程序 获得群窗口

句柄 = FindWindowExA (0, 0, “QWidget”, 0)
.判断循环首 (句柄 ≠ 0)
    窗口_取控件大小 (句柄, 宽度1, 高度1)
    .如果真 (高度1 = 500 且 宽度1 = 610)
        跳出循环 ()
    .如果真结束
    句柄 = FindWindowExA (0, 句柄, “QWidget”, 0)
.判断循环尾 ()

.子程序 取发送频率, 整数型

.判断开始 (单次频率1.内容 = 单次频率2.内容)
    返回 (到整数 (单次频率2.内容) × 1000)
.默认
    返回 (取一个随机数 (到整数 (单次频率1.内容), 到整数 (单次频率2.内容)) × 1000)
.判断结束


.子程序 YY群成员
.局部变量 临时内容, 文本型
.局部变量 子内容, 文本型, , "0"
.局部变量 局部计次, 整数型
.局部变量 群窗口, 整数型

获得群窗口 ()
群窗口 = 句柄
鼠标_消息 (群窗口, 491, 365)
.判断循环首 (状态)
    等待输入验证码 ()
    键盘消息 (群窗口, #下光标键)
    程序_延时 (300)
    键盘消息 (群窗口, #回车键)
    程序_延时 (1000)
    获得好友窗口 ()
    等待输入验证码 ()
    临时内容 = 筛选内容 ()
    .判断开始 (寻找文本 (临时内容, “~”, , 真) = -1)
        文本_投递 (句柄, 临时内容)
        程序_延时 (500)
        鼠标_消息 (句柄, 332, 480)
    .默认
        清除数组 (子内容)
        子内容 = 分割文本 (临时内容, “~”, )
        .计次循环首 (取数组成员数 (子内容), 局部计次)
            等待输入验证码 ()
            文本_投递 (句柄, 子内容 [局部计次])
            程序_延时 (500)
            鼠标_消息 (句柄, 332, 480)
            程序_延时 (1000)
        .计次循环尾 ()
    .判断结束
    总计次 = 总计次 + 1
    程序_延时 (取两者差 (单次频率1, 单次频率2))
    PostMessageA (句柄, 16, 0, 0)
    程序_延时 (200)
    计次延时 ()
.判断循环尾 ()

.子程序 计次延时
.局部变量 局部, 整数型

.如果真 (总计次 ≥ 取两者差 (发送次数1, 发送次数2) ÷ 1000)
    总计次 = 0
    程序_延时 (取两者差 (计次休息1, 计次休息2))
.如果真结束


.子程序 取两者差, 整数型
.参数 编辑框A, 编辑框
.参数 编辑框B, 编辑框

.判断开始 (编辑框A = 编辑框B)
    返回 (到整数 (编辑框A.内容) × 1000)
.默认
    返回 (取一个随机数 (到整数 (编辑框A.内容), 到整数 (编辑框B.内容)) × 1000)
.判断结束


.子程序 YY工会私密
.局部变量 临时内容, 文本型
.局部变量 子内容, 文本型, , "0"
.局部变量 局部计次, 整数型
.局部变量 群窗口, 整数型



.子程序 _停止_被单击

状态 = 假
窗口1.位置 = 1

.子程序 键盘消息, , 公开
.参数 窗口句柄, 整数型
.参数 键代码, 整数型

PostMessageA (窗口句柄, 256, 键代码, 0)

.子程序 取一个随机数, 整数型, 公开, 无需置随机种子
.参数 最小值, 整数型
.参数 最大值, 整数型

置入代码 ({ 81, 82, 15, 49, 185, 23, 0, 0, 0, 247, 225, 131, 192, 7, 139, 77, 12, 43, 77, 8, 65, 49, 210, 247, 241, 3, 85, 8, 137, 208, 90, 89, 201, 194, 8, 0 })
返回 (0)
善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
快速回复
限100 字节
如果您在写长篇帖子又不马上发表,建议存为草稿
 
上一个 下一个