• 1287阅读
  • 1回复

POST实战演练 第14课:添加YY工会私密功能,做收尾的检查整理,增加简易商业软件注册系统 [复制链接]

上一主题 下一主题
离线啊冲
 

只看楼主 倒序阅读 使用道具 楼主  发表于: 2016-08-30
.版本 2

.程序集 窗口程序集1
.程序集变量 状态, 逻辑型, , , 真为运行
.程序集变量 高度1, 整数型
.程序集变量 宽度1, 整数型
.程序集变量 句柄, 整数型
.程序集变量 总计次, 整数型
.程序集变量 轮流, 整数型

.子程序 _窗口1_将被销毁

结束 ()

.子程序 _开始_被单击

窗口1.位置 = 2
状态 = 真
.如果真 (YY好友.选中)
    YY好友 ()
.如果真结束

.如果真 (YY群成员.选中)
    YY群成员 ()
.如果真结束

.如果真 (YY工会私密.选中)
    YY工会私密 ()
.如果真结束
窗口1.位置 = 1

.子程序 筛选内容, 文本型
.局部变量 分割, 文本型, , "0"

.判断开始 (寻找文本 (发送内容.内容, “~~~~”, , 假) = -1)
    返回 (发送内容.内容)
.默认
    分割 = 分割文本 (发送内容.内容, “~~~~”, )
    轮流 = 轮流 + 1
    .如果真 (轮流 > 取数组成员数 (分割))
        轮流 = 1
    .如果真结束
    返回 (分割 [轮流])
.判断结束


.子程序 YY好友
.局部变量 临时内容, 文本型
.局部变量 主窗口, 整数型
.局部变量 子内容, 文本型, , "0"
.局部变量 局部计次, 整数型

主窗口 = 进程_名取句柄 (“YY.exe”)
.判断循环首 (状态)
    键盘消息 (主窗口, #下光标键)
    程序_延时 (300)
    键盘消息 (主窗口, #回车键)
    程序_延时 (1000)
    获得好友窗口 ()
    临时内容 = 筛选内容 ()
    .判断开始 (寻找文本 (临时内容, “~”, , 真) = -1)
        等待输入验证码 ()
        文本_投递 (句柄, 临时内容)
        程序_延时 (500)
        鼠标_消息 (句柄, 332, 480)
    .默认
        清除数组 (子内容)
        子内容 = 分割文本 (临时内容, “~”, )
        .计次循环首 (取数组成员数 (子内容), 局部计次)
            等待输入验证码 ()
            文本_投递 (句柄, 子内容 [局部计次])
            程序_延时 (500)
            鼠标_消息 (句柄, 332, 480)
            程序_延时 (1000)
        .计次循环尾 ()
    .判断结束
    总计次 = 总计次 + 1
    程序_延时 (取两者差 (单次频率1, 单次频率2))
    PostMessageA (句柄, 16, 0, 0)
    程序_延时 (200)
    计次延时 ()
.判断循环尾 ()

.子程序 等待输入验证码

.判断循环首 (FindWindowA (“QWidget”, “临时会话”) ≠ 0)
    程序_延时 (1000)
.判断循环尾 ()

.子程序 获得好友窗口

句柄 = FindWindowExA (0, 0, “QWidget”, 0)
.判断循环首 (句柄 ≠ 0)
    窗口_取控件大小 (句柄, 宽度1, 高度1)
    .如果真 (高度1 = 500 且 宽度1 = 550)
        跳出循环 ()
    .如果真结束
    句柄 = FindWindowExA (0, 句柄, “QWidget”, 0)
.判断循环尾 ()

.子程序 获得群窗口

句柄 = FindWindowExA (0, 0, “QWidget”, 0)
.判断循环首 (句柄 ≠ 0)
    窗口_取控件大小 (句柄, 宽度1, 高度1)
    .如果真 (高度1 = 500 且 宽度1 = 610)
        跳出循环 ()
    .如果真结束
    句柄 = FindWindowExA (0, 句柄, “QWidget”, 0)
.判断循环尾 ()

.子程序 取发送频率, 整数型

.判断开始 (单次频率1.内容 = 单次频率2.内容)
    返回 (到整数 (单次频率2.内容) × 1000)
.默认
    返回 (取一个随机数 (到整数 (单次频率1.内容), 到整数 (单次频率2.内容)) × 1000)
.判断结束


.子程序 YY群成员
.局部变量 临时内容, 文本型
.局部变量 子内容, 文本型, , "0"
.局部变量 局部计次, 整数型
.局部变量 群窗口, 整数型

获得群窗口 ()
群窗口 = 句柄
.判断循环首 (状态)
    键盘消息 (群窗口, #下光标键)
    程序_延时 (300)
    键盘消息 (群窗口, #回车键)
    程序_延时 (1000)
    获得好友窗口 ()
    临时内容 = 筛选内容 ()
    .判断开始 (寻找文本 (临时内容, “~”, , 真) = -1)
        等待输入验证码 ()
        文本_投递 (句柄, 临时内容)
        程序_延时 (500)
        鼠标_消息 (句柄, 332, 480)
    .默认
        清除数组 (子内容)
        子内容 = 分割文本 (临时内容, “~”, )
        .计次循环首 (取数组成员数 (子内容), 局部计次)
            等待输入验证码 ()
            文本_投递 (句柄, 子内容 [局部计次])
            程序_延时 (500)
            鼠标_消息 (句柄, 332, 480)
            程序_延时 (1000)
        .计次循环尾 ()
    .判断结束
    总计次 = 总计次 + 1
    程序_延时 (取两者差 (单次频率1, 单次频率2))
    PostMessageA (句柄, 16, 0, 0)
    程序_延时 (200)
    计次延时 ()
.判断循环尾 ()

.子程序 计次延时
.局部变量 局部, 整数型

.如果真 (总计次 ≥ 取两者差 (发送次数1, 发送次数2) ÷ 1000)
    总计次 = 0
    程序_延时 (取两者差 (计次休息1, 计次休息2))
.如果真结束


.子程序 获得工会窗口

句柄 = FindWindowExA (0, 0, “QWidget”, 0)
.判断循环首 (句柄 ≠ 0)
    窗口_取控件大小 (句柄, 宽度1, 高度1)
    .如果真 (高度1 = 566)
        跳出循环 ()
    .如果真结束
    句柄 = FindWindowExA (0, 句柄, “QWidget”, 0)
.判断循环尾 ()

.子程序 YY工会私密
.局部变量 临时内容, 文本型
.局部变量 子内容, 文本型, , "0"
.局部变量 局部计次, 整数型
.局部变量 工会窗口, 整数型

获得工会窗口 ()
工会窗口 = 句柄
.判断循环首 (状态)
    循环关闭窗口 (“QPopup”, “YY”)
    鼠标_消息 (工会窗口, 71, 505)
    程序_延时 (100)
    键盘消息 (工会窗口, #下光标键)
    程序_延时 (300)
    鼠标_消息 (工会窗口, 71, 505, 2)
    程序_延时 (300)
    鼠标_消息 (FindWindowA (“QPopup”, “YY”), 5, 5)
    程序_延时 (300)
    临时内容 = 筛选内容 ()
    .判断开始 (寻找文本 (临时内容, “~”, , 真) = -1)
        等待输入验证码 ()
        文本_投递 (工会窗口, 临时内容)
        程序_延时 (500)
        鼠标_消息 (工会窗口, 708, 548)
    .默认
        清除数组 (子内容)
        子内容 = 分割文本 (临时内容, “~”, )
        .计次循环首 (取数组成员数 (子内容), 局部计次)
            等待输入验证码 ()
            文本_投递 (工会窗口, 子内容 [局部计次])
            程序_延时 (500)
            鼠标_消息 (工会窗口, 708, 548)
            程序_延时 (2000)
        .计次循环尾 ()
    .判断结束
    总计次 = 总计次 + 1
    程序_延时 (取两者差 (单次频率1, 单次频率2))
    程序_延时 (200)
    计次延时 ()
.判断循环尾 ()

.子程序 _停止_被单击

状态 = 假
窗口1.位置 = 1

.子程序 _窗口1_创建完毕

' 生成注册文件到桌面 (取CPU序列号1 ())
.如果真 (校验_取md5 (到字节集 (文本_解密 (到文本 (读入文件 (取运行目录 () + “\zcm.key”)), “精易论坛”))) ≠ 校验_取md5 (到字节集 (取CPU序列号1 ())))
    置剪辑板文本 (取CPU序列号1 ())
    MessageBoxA (取窗口句柄 (), “您的机器码为” + 取剪辑板文本 () + #换行符 + “已经复制到剪辑版!”, “软件尚未注册:”, 0)
    结束 ()
.如果真结束


.子程序 _关于_被单击

MessageBoxA (取窗口句柄 (), “精易论坛 www.3600gz.cn”, “关于:”, 0)

.子程序 _窗口1_位置被改变

善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
离线啊冲

只看该作者 沙发  发表于: 2016-08-30
综合实例:

YY系列 第5课 YY推广工具(三)

教程内容:添加YY工会私密功能,做收尾的检查整理,增加简易商业软件注册系统


1、将免费版本和商业版本区分开
2、软件内部做版权的防修改
3、商业版必须加壳(加壳工具在教程文档里)
4、商业版内设置内存迷幻器
5、设置暗桩

.版本 2

.程序集 窗口程序集_字符串搅乱器

.子程序 _按钮4_被单击

编辑框2.内容 = 普通文本到字节集文本 (编辑框1.内容)

.子程序 普通文本到字节集文本, 文本型
.参数 普通文本, 文本型
.局部变量 临时文本, 文本型
.局部变量 计次, 整数型

临时文本 = “”
.计次循环首 (取文本长度 (普通文本), 计次)
    .如果 (取代码 (普通文本, 计次) > 0)
        临时文本 = 临时文本 + 到文本 (取代码 (普通文本, 计次))
    .否则
        临时文本 = 临时文本 + 到文本 (256 + 取代码 (普通文本, 计次))
    .如果结束
    .如果真 (取文本长度 (普通文本) - 计次 > 0)
        临时文本 = 临时文本 + “,”
    .如果真结束

.计次循环尾 ()
返回 (“{ ” + 临时文本 + “ }”)


.子程序 _按钮2_被单击
.局部变量 临时文本, 文本型

临时文本 = 还原字节集文本为普通文本 (编辑框2.内容)
编辑框3.内容 = 临时文本
.如果 (编辑框1.内容 = 编辑框3.内容)
    标签3.标题 = “验证正确:编辑框中内容相同!”
.否则
    标签3.标题 = “验证错误:编辑框中内容不同!”
.如果结束


.子程序 还原字节集文本为普通文本, 文本型
.参数 字节集文本, 文本型
.局部变量 临时文本, 文本型
.局部变量 临时文本数组, 文本型, , "0"
.局部变量 计次, 整数型

临时文本 = “”
临时文本 = 子文本替换 (字节集文本, “{”, , , , 假)
临时文本 = 子文本替换 (临时文本, “}”, , , , 假)
临时文本数组 = 分割文本 (临时文本, “,”, )
临时文本 = “”
.计次循环首 (取数组成员数 (临时文本数组), 计次)
    临时文本 = 临时文本 + 到文本 (字符 (到字节 (临时文本数组 [计次])))
.计次循环尾 ()
返回 (临时文本)


.子程序 随机搅乱
.局部变量 随机数, 整数型
.局部变量 临时文本, 文本型
.局部变量 计次, 整数型

临时文本 = “”
.计次循环首 (取文本长度 (编辑框1.内容), 计次)

    .如果 (取代码 (编辑框1.内容, 计次) ≥ 48 且 取代码 (编辑框1.内容, 计次) ≤ 57)  ' 在数字范围之内
        随机数 = 取随机数 (1, 4)
        .判断开始 (随机数 = 1)  ' 加法处理
            临时文本 = 临时文本 + 加法处理 (取文本中间 (编辑框1.内容, 计次, 1))
        .判断 (随机数 = 2)  ' 减法处理
            临时文本 = 临时文本 + 减法处理 (取文本中间 (编辑框1.内容, 计次, 1))
        .判断 (随机数 = 3)  ' 乘法处理
            临时文本 = 临时文本 + 乘法处理 (取文本中间 (编辑框1.内容, 计次, 1))
        .判断 (随机数 = 4)  ' 除法处理
            临时文本 = 临时文本 + 除法处理 (取文本中间 (编辑框1.内容, 计次, 1))
        .判断 (随机数 = 5)  ' 取余数,整除,取整,四舍五入,处理

        .判断 (随机数 = 6)  ' 位运算

        .判断 (随机数 = 7)  ' 求平方根处理

        .判断 (随机数 = 8)  ' 求次方处理

        .默认

        .判断结束


    .否则

        随机数 = 取随机数 (1, 9)
        .判断开始 (随机数 = 2)
            .如果 (取代码 (编辑框1.内容, 计次) > 0)  ' 如果是汉字,会产生乱码哦,最好就字母按原样可以排.
                临时文本 = 临时文本 + #左引号 + 取文本中间 (编辑框1.内容, 计次, 1) + #右引号  ' 按原来的字母排
            .否则
                临时文本 = 临时文本 + “字符(” + 到文本 (256 + 取代码 (编辑框1.内容, 计次)) + “)”
            .如果结束

        .默认
            .如果 (取代码 (编辑框1.内容, 计次) > 0)
                临时文本 = 临时文本 + “字符(” + 到文本 (取代码 (编辑框1.内容, 计次)) + “)”
            .否则
                临时文本 = 临时文本 + “字符(” + 到文本 (256 + 取代码 (编辑框1.内容, 计次)) + “)”
            .如果结束

        .判断结束

    .如果结束

    .如果真 (取文本长度 (编辑框1.内容) - 计次 > 0)
        临时文本 = 临时文本 + “+”
    .如果真结束

.计次循环尾 ()
编辑框2.内容 = 临时文本


.子程序 _按钮3_被单击
.局部变量 字符串, 文本型

字符串 = 到文本 ({ 214 }) + 字符 (位异或 (213, 5)) + 到文本 ({ 185 }) + 字符 (位异或 (255, 5)) + 到文本 ({ 200 }) + 字符 (位异或 (206, 5)) + 到文本 ({ 195 }) + 字符 (位异或 (244, 5)) + 到文本 ({ 189 }) + 字符 (位异或 (231, 5)) + 到文本 ({ 183 }) + 字符 (位异或 (192, 5)) + 到文本 ({ 190 }) + 字符 (位异或 (249, 5))
信息框 (字符串, 0, )
.如果 (编辑框1.内容 = 字符串)
    信息框 (“正确:与上边的编辑框内容相同!!”, 0, )
.否则
    信息框 (“错误:与上边的编辑框内容不同!!”, 0, )
.如果结束


.子程序 加法处理, 文本型
.参数 原数据文本, 文本型
.局部变量 结果数据文本, 文本型
.局部变量 临时随机数, 整数型

临时随机数 = 取随机数 (0, 到数值 (原数据文本))
结果数据文本 = “到文本(” + 到文本 (到数值 (原数据文本) - 到数值 (临时随机数)) + “+” + 到文本 (到数值 (临时随机数)) + “)”
返回 (结果数据文本)


.子程序 减法处理, 文本型
.参数 原数据文本, 文本型
.局部变量 结果数据文本, 文本型
.局部变量 临时随机数, 整数型

临时随机数 = 取随机数 (0, 到数值 (原数据文本))
结果数据文本 = “到文本(” + 到文本 (到数值 (原数据文本) + 到数值 (临时随机数)) + “-” + 到文本 (到数值 (临时随机数)) + “)”
返回 (结果数据文本)


.子程序 乘法处理, 文本型
.参数 原数据文本, 文本型
.局部变量 结果数据文本, 文本型

.判断开始 (到数值 (原数据文本) % 2 = 0)
    结果数据文本 = “到文本(” + 到文本 (到数值 (原数据文本) ÷ 2) + “*2)”
.判断 (到数值 (原数据文本) % 3 = 0)
    结果数据文本 = “到文本(” + 到文本 (到数值 (原数据文本) ÷ 3) + “*3)”
.判断 (到数值 (原数据文本) % 5 = 0)
    结果数据文本 = “到文本(” + 到文本 (到数值 (原数据文本) ÷ 5) + “*5)”
.判断 (到数值 (原数据文本) % 7 = 0)
    结果数据文本 = “到文本(” + 到文本 (到数值 (原数据文本) ÷ 7) + “*7)”
.默认
    结果数据文本 = “到文本(” + 原数据文本 + “*1)”
.判断结束
返回 (结果数据文本)


.子程序 除法处理, 文本型
.参数 原数据文本, 文本型
.局部变量 结果数据文本, 文本型
.局部变量 临时随机数, 整数型

.如果真 (原数据文本 = “0”)
    返回 (“到文本(0)”)
.如果真结束
临时随机数 = 取随机数 (1, 9)
.判断开始 (临时随机数 = 1)
    结果数据文本 = “到文本(” + 到文本 (到数值 (原数据文本) × 1) + “/1)”
.判断 (临时随机数 = 2)
    结果数据文本 = “到文本(” + 到文本 (到数值 (原数据文本) × 2) + “/2)”
.判断 (临时随机数 = 3)
    结果数据文本 = “到文本(” + 到文本 (到数值 (原数据文本) × 3) + “/3)”
.判断 (临时随机数 = 4)
    结果数据文本 = “到文本(” + 到文本 (到数值 (原数据文本) × 4) + “/4)”
.判断 (临时随机数 = 5)
    结果数据文本 = “到文本(” + 到文本 (到数值 (原数据文本) × 5) + “/5)”
.判断 (临时随机数 = 6)
    结果数据文本 = “到文本(” + 到文本 (到数值 (原数据文本) × 6) + “/6)”
.判断 (临时随机数 = 7)
    结果数据文本 = “到文本(” + 到文本 (到数值 (原数据文本) × 7) + “/7)”
.判断 (临时随机数 = 8)
    结果数据文本 = “到文本(” + 到文本 (到数值 (原数据文本) × 8) + “/8)”
.判断 (临时随机数 = 9)
    结果数据文本 = “到文本(” + 到文本 (到数值 (原数据文本) × 9) + “/9)”
.默认

.判断结束
返回 (结果数据文本)


.子程序 交叉搅乱
.局部变量 临时文本, 文本型
.局部变量 计次, 整数型

临时文本 = “”
.计次循环首 (取文本长度 (编辑框1.内容), 计次)
    .如果真 (选择框_字符.选中 = 真 且 选择框_字节集.选中 = 真)
        .如果 (计次 % 2 = 0)
            .如果 (取代码 (编辑框1.内容, 计次) > 0)
                .如果 (选择框_位异或.选中 = 真 且 取文本长度 (编辑框4.内容) ≥ 1)
                    临时文本 = 临时文本 + “字符(位异或(” + 到文本 (位异或 (取代码 (编辑框1.内容, 计次), 到数值 (编辑框4.内容))) + “,” + 编辑框4.内容 + “))”
                .否则
                    临时文本 = 临时文本 + “字符(” + 到文本 (取代码 (编辑框1.内容, 计次)) + “)”
                .如果结束

            .否则
                .如果 (选择框_位异或.选中 = 真 且 取文本长度 (编辑框4.内容) ≥ 1)
                    临时文本 = 临时文本 + “字符(位异或(” + 到文本 (位异或 (256 + 取代码 (编辑框1.内容, 计次), 到数值 (编辑框4.内容))) + “,” + 编辑框4.内容 + “))”
                .否则
                    临时文本 = 临时文本 + “字符(” + 到文本 (256 + 取代码 (编辑框1.内容, 计次)) + “)”
                .如果结束

            .如果结束

        .否则
            .如果 (取代码 (编辑框1.内容, 计次) > 0)  ' 到文本 (位异或 (到整数 (取代码 (到文本 ({ 67 }), 5))
                临时文本 = 临时文本 + “到文本({” + 到文本 (取代码 (编辑框1.内容, 计次)) + “})”
            .否则
                临时文本 = 临时文本 + “到文本({” + 到文本 (256 + 取代码 (编辑框1.内容, 计次)) + “})”
            .如果结束

        .如果结束

    .如果真结束

    .如果真 (选择框_字符.选中 = 真 且 选择框_字节集.选中 = 假)
        .如果 (取代码 (编辑框1.内容, 计次) > 0)
            .如果 (选择框_位异或.选中 = 真 且 取文本长度 (编辑框4.内容) ≥ 1)
                .如果 (选择框_位异或.选中 = 真 且 取文本长度 (编辑框4.内容) ≥ 1)
                    临时文本 = 临时文本 + “字符(位异或(” + 到文本 (位异或 (取代码 (编辑框1.内容, 计次), 到数值 (编辑框4.内容))) + “,” + 编辑框4.内容 + “))”
                .否则
                    临时文本 = 临时文本 + “字符(” + 到文本 (取代码 (编辑框1.内容, 计次)) + “)”
                .如果结束

            .否则
                .如果 (选择框_位异或.选中 = 真 且 取文本长度 (编辑框4.内容) ≥ 1)
                    临时文本 = 临时文本 + “字符(位异或(” + 到文本 (位异或 (256 + 取代码 (编辑框1.内容, 计次), 到数值 (编辑框4.内容))) + “,” + 编辑框4.内容 + “))”
                .否则
                    临时文本 = 临时文本 + “字符(” + 到文本 (256 + 取代码 (编辑框1.内容, 计次)) + “)”
                .如果结束

            .如果结束

        .否则
            临时文本 = 临时文本 + “字符(” + 到文本 (256 + 取代码 (编辑框1.内容, 计次)) + “)”
        .如果结束

    .如果真结束

    .如果真 (选择框_字符.选中 = 假 且 选择框_字节集.选中 = 真)
        .如果 (取代码 (编辑框1.内容, 计次) > 0)
            临时文本 = 临时文本 + “到文本({” + 到文本 (取代码 (编辑框1.内容, 计次)) + “})”
        .否则
            临时文本 = 临时文本 + “到文本({” + 到文本 (256 + 取代码 (编辑框1.内容, 计次)) + “})”
        .如果结束

    .如果真结束

    .如果真 (取文本长度 (编辑框1.内容) - 计次 > 0)
        临时文本 = 临时文本 + “+”
    .如果真结束

.计次循环尾 ()
编辑框2.内容 = 临时文本


.子程序 _按钮6_被单击

信息框 (位异或 (14, 6), 0, )


.子程序 _按钮1_被单击


.判断开始 (单选框1_全部选中.选中 = 真)
    随机搅乱 ()  ' 正确
.判断 (单选框2_字符相加.选中 = 真)
    交叉搅乱 ()  ' 正确
.判断 (单选框3_科学计算.选中 = 真)

.判断 (单选框4_累加代码.选中 = 真)

.默认

.判断结束


.子程序 _单选框1_全部选中_被单击

连续赋值 (假, 选择框_取反.选中, 选择框_字符.选中, 选择框_到数值.选中, 选择框_字节集.选中, 选择框_位异或.选中, 选择框_到整数.选中, 选择框_取代码.选中, 选择框_科学计算.选中, 选择框_进制转换.选中, 选择框_算术运算.选中, 选择框_加减乘除.选中)
连续赋值 (真, 选择框_取反.选中, 选择框_字符.选中, 选择框_字节集.选中, 选择框_位异或.选中, 选择框_到整数.选中, 选择框_取代码.选中, 选择框_进制转换.选中, 选择框_算术运算.选中, 选择框_加减乘除.选中)

.子程序 _单选框2_字符相加_被单击

连续赋值 (假, 选择框_取反.选中, 选择框_字符.选中, 选择框_到数值.选中, 选择框_字节集.选中, 选择框_位异或.选中, 选择框_到整数.选中, 选择框_取代码.选中, 选择框_科学计算.选中, 选择框_进制转换.选中, 选择框_算术运算.选中, 选择框_加减乘除.选中)
连续赋值 (真, 选择框_字符.选中, 选择框_字节集.选中, 选择框_位异或.选中)

.子程序 _单选框3_科学计算_被单击

连续赋值 (假, 选择框_取反.选中, 选择框_字符.选中, 选择框_到数值.选中, 选择框_字节集.选中, 选择框_位异或.选中, 选择框_到整数.选中, 选择框_取代码.选中, 选择框_科学计算.选中, 选择框_进制转换.选中, 选择框_算术运算.选中, 选择框_加减乘除.选中)
连续赋值 (真, 选择框_字符.选中, 选择框_字节集.选中, 选择框_科学计算.选中)

.子程序 字符相加
.局部变量 临时文本, 文本型
.局部变量 计次, 整数型

临时文本 = “”
.计次循环首 (取文本长度 (编辑框1.内容), 计次)
    .如果 (取代码 (编辑框1.内容, 计次) > 0)
        临时文本 = 临时文本 + “字符(” + 到文本 (取代码 (编辑框1.内容, 计次)) + “)”
    .否则
        临时文本 = 临时文本 + “字符(” + 到文本 (256 + 取代码 (编辑框1.内容, 计次)) + “)”
    .如果结束

    .如果真 (取文本长度 (编辑框1.内容) - 计次 > 0)
        临时文本 = 临时文本 + “+”
    .如果真结束

.计次循环尾 ()
编辑框2.内容 = 临时文本


.子程序 字节集相加
.局部变量 临时文本, 文本型
.局部变量 计次, 整数型

临时文本 = “”
.计次循环首 (取文本长度 (编辑框1.内容), 计次)
    .如果 (取代码 (编辑框1.内容, 计次) > 0)
        临时文本 = 临时文本 + “到文本({” + 到文本 (取代码 (编辑框1.内容, 计次)) + “})”
    .否则
        临时文本 = 临时文本 + “到文本({” + 到文本 (256 + 取代码 (编辑框1.内容, 计次)) + “})”
    .如果结束

    .如果真 (取文本长度 (编辑框1.内容) - 计次 > 0)
        临时文本 = 临时文本 + “+”
    .如果真结束

.计次循环尾 ()
编辑框2.内容 = 临时文本

善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
快速回复
限100 字节
如果您在写长篇帖子又不马上发表,建议存为草稿
 
上一个 下一个