• 1067阅读
  • 1回复

POST实战演练  第15课:重新剖析YY账号注册 [复制链接]

上一主题 下一主题
离线啊冲
 

只看楼主 倒序阅读 使用道具 楼主  发表于: 2016-08-30

.版本 2
.支持库 spec
.支持库 script

.程序集 窗口程序集1

.子程序 _图片框1_鼠标左键被放开, 逻辑型
.参数 横向位置, 整数型
.参数 纵向位置, 整数型
.参数 功能键状态, 整数型

读验证码 ()

.子程序 _窗口1_创建完毕

编辑框1.内容 = 生成随机帐号 ()
编辑框2.内容 = 生成随机密码 ()
读验证码 ()

.子程序 _按钮1_被单击

调试输出 (注册YY帐号 (编辑框1.内容, 编辑框2.内容, 编辑框3.内容))
读验证码 ()
编辑框1.内容 = 生成随机帐号 ()
编辑框2.内容 = 生成随机密码 ()

.子程序 注册YY帐号, 逻辑型
.参数 帐号, 文本型
.参数 密码, 文本型
.参数 验证码, 文本型
.局部变量 正则, 正则表达式类
.局部变量 i, 整数型
.局部变量 返回内容, 文本型
.局部变量 数据, 文本型
.局部变量 地址, 文本型
.局部变量 参数1, 文本型
.局部变量 参数2, 文本型
.局部变量 rcall, 文本型
.局部变量 timer4reg, 文本型

返回内容 = 编码_Utf8到Ansi (网页_访问 (“https://udb.duowan.com/register/core.do?regType=inner&appid=1&url=”, , , , , , , , , , ))
正则.创建 (#正则1, 返回内容, , , 真)
参数1 = 正则.取子匹配文本 (1, 1, )
参数2 = 正则.取子匹配文本 (1, 2, )
timer4reg = 正则.取子匹配文本 (1, 3, )
rcall = 正则.取子匹配文本 (1, 4, )
地址 = “https://udb.duowan.com/registerV2/” + 取登录页面 (rcall) + “.do”
数据 = “url=&appid=1&regType=inner&” + 参数1 + “=” + 参数2 + “&timer4reg=” + timer4reg + “&rcall=” + rcall + “&username=” + 帐号 + “&password=” + 密码 + “&securityCode1=” + 验证码
延迟 (6000)
返回内容 = 编码_Utf8到Ansi (网页_访问 (地址, 1, , , 到字节集 (数据), , , , , , ))
调试输出 (返回内容)
.判断开始 (寻找文本 (返回内容, “正在登录”, , 假) > 1)
    返回 (真)
.默认
    返回 (假)
.判断结束


.子程序 读验证码

网页_清除Cookie (“udb.duowan.com”)
编辑框3.内容 = “”
图片框1.图片 = 网页_访问 (“https://udb.duowan.com/verify/register.do?” + 到文本 (时间_北京转格林威治 (取现行时间 ())), , , , , , , , , , )

.子程序 生成随机帐号, 文本型

返回 (文本_取随机字母 (4) + 文本_取随机数字 (10))

.子程序 生成随机密码, 文本型

返回 (文本_取随机字母 (2) + 文本_取随机数字 (10))

.子程序 取登录页面, 文本型
.参数 rcall1, 文本型

脚本组件1.执行 (#login)
返回 (脚本组件1.运行 (“formSubmit”, rcall1))
善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
离线啊冲

只看该作者 沙发  发表于: 2016-08-30
  综合实例:
  
  YY系列 第一课 帐号的注册  讲师:小磊

  网页地址:https://udb.duowan.com/register.do

  目标:封包的分析,简单编写登录测试程序

  封包分析流程:抓包(一般为两次)→ 找到关键包→对比数据找出已知数据和未知数据→向上查找未知数据

  错误排除流程:检查提交地址→检查POST或GET数据→检查提交的cookies→检查附加协议头→检查时间轴
善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
快速回复
限100 字节
如果您提交过一次失败了,可以用”恢复数据”来恢复帖子内容
 
上一个 下一个