• 966阅读
  • 0回复

任鸟飞易语言外挂第2期QQ仙侠传游戏辅助制作教程 第一课 大漠和自动登录 [复制链接]

上一主题 下一主题
离线啊冲
 

只看楼主 倒序阅读 使用道具 楼主  发表于: 2016-09-01

.版本 2

.程序集 窗口程序集1
.程序集变量 大漠, 大漠中文版
.程序集变量 窗口句柄, 整数型
.程序集变量 x, 变体型
.程序集变量 y, 变体型

.子程序 __启动窗口_创建完毕

.如果真 (大漠注册 (取运行目录 () + “\dm.dll”) = 真)
    大漠.创建对象 ()

.如果真结束


.子程序 _按钮1_被单击
.局部变量 m, 整数型
.局部变量 n, 整数型


进程_创建进程 (编辑框1.内容)
超级延时 (1000)

.循环判断首 ()

    窗口句柄 = 窗口_取窗口句柄 (, “QQ仙侠传登录程序”, 真)
    超级延时 (200)

.循环判断尾 (窗口句柄 = 0)  ' 窗口句柄=0 说明    窗口没有创建成功    窗口句柄!=0   创建成功


.循环判断首 ()

    大漠.找图 (0, 0, 2000, 2000, 取运行目录 () + “\开始游戏.bmp”, “101010”, 0.9, 0, x, y)
    超级延时 (200)

.循环判断尾 (x.取数值 () < 1)  ' x.取数值 () < 1   没有找到图片

大漠.移动鼠标 (x.取数值 (), y.取数值 ())
超级延时 (500)
大漠.左键单击 ()
超级延时 (1000)



.循环判断首 ()

    大漠.找图 (0, 0, 2000, 2000, 取运行目录 () + “\登陆游戏.bmp”, “101010”, 0.9, 0, x, y)
    超级延时 (200)

.循环判断尾 (x.取数值 () < 1)  ' x.取数值 () < 1   没有找到图片


.如果真 (x.取数值 () > 1)

    大漠.移动鼠标 (x.取数值 (), y.取数值 () - 135)
    超级延时 (200)
    大漠.左键单击 ()
    超级延时 (200)

    .计次循环首 (11, n)

        大漠.按键 (8)
        超级延时 (100)
    .计次循环尾 ()  ' '''''''''''''''''''''''删除已有的账号

    输出文本 (编辑框2.内容)

    大漠.按键 (9)
    超级延时 (200)

    输出文本 (编辑框3.内容)

    超级延时 (200)

    大漠.按键 (13)  ' ''''''''''''''''''回车
    超级延时 (2000)

.如果真结束

善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
快速回复
限100 字节
批量上传需要先选择文件,再选择上传
 
上一个 下一个