刺激战场
  • 1228阅读
  • 0回复

任鸟飞易语言外挂第2期  第3课 EXE怎么显示 角色信息 [复制链接]

上一主题 下一主题
离线啊冲
 

只看楼主 倒序阅读 使用道具 楼主  发表于: 2016-09-01

任鸟飞2015完整辅助开发+全套源码价值2000

http://www.lthack.com/thread-7768-1-1.html

(出处: 龙天论坛_全网最大百度云盘资源分享基地)


任鸟飞第四期易语言外挂射雕英雄传游戏辅助教程

http://www.lthack.com/thread-9334-1-1.html

(出处: 龙天论坛_全网最大百度云盘资源分享基地)


龙天论坛
http://www.lthack.com

企业客服:800089037
技术客服:1605895869
龙天技术交流群:244355778

第3课 EXE怎么显示 角色信息
EXE 注入DLL  DLL 就是游戏进程的一部分  DLL 可以直接读取游戏的数据
共享内存


[[00BBDA9C]+4]+8人物ID
[[00BBDA9C]+4]+C人物系统ID
[[[[[00BBEA9C]+4]+2c]]+10]
+280 经验值  双浮点
+288 经验最大值  双浮点
+294 ASCII宽文本   角色名称
+40  双浮点 血
+48  双浮点 蓝
+30  双浮点 最大血
+38  双浮点 最大蓝
+190 双浮点 等级
+1C8 最大物理攻击
+1D0 最小物理攻击
[[[[00BBDA9C]+4]+24]+8]+628  32位浮点型X坐标
[[[[00BBDA9C]+4]+24]+8]+62C  32位浮点型Y坐标



.版本 2

.程序集 窗口程序集1
.程序集变量 共享, 类_共享内存
.程序集变量 返回, 逻辑型

.子程序 _窗口1_创建完毕

时钟1.时钟周期 = 5000
_时钟1_周期事件 ()
返回 = 共享.创建内存 (“共享内存”, 4096)
标签1.标题 = 到文本 (返回)

.子程序 _时钟1_周期事件
.局部变量 偏移, 整数型
.局部变量 人物名称, 文本型
.局部变量 血, 双精度小数型
.局部变量 蓝, 双精度小数型
.局部变量 最大血, 双精度小数型
.局部变量 最大蓝, 双精度小数型

内存_读整数型 (-1, 十六到十 (“00BBeA9C”), 偏移, , )  ' [00BBEA9C]
内存_读整数型 (-1, 偏移 + 十六到十 (“4”), 偏移, , )  ' [[00BBEA9C]+4]
内存_读整数型 (-1, 偏移 + 十六到十 (“2c”), 偏移, , )  ' [[[00BBEA9C]+4]+2c]
内存_读整数型 (-1, 偏移, 偏移, , )  ' [[[[00BBEA9C]+4]+2c]]
内存_读整数型 (-1, 偏移 + 十六到十 (“10”), 偏移, , )  ' ' [[[[[00BBEA9C]+4]+2c]]+10]

内存_读文本型 (-1, 偏移 + 十六到十 (“294”), 人物名称, , )  ' ' [[[[[00BBEA9C]+4]+2c]]+10]+294

内存_读双精度小数型 (-1, 偏移 + 十六到十 (“40”), 血, , )  ' ' [[[[[00BBEA9C]+4]+2c]]+10]+294
内存_读双精度小数型 (-1, 偏移 + 十六到十 (“48”), 蓝, , )  ' ' [[[[[00BBEA9C]+4]+2c]]+10]+294
内存_读双精度小数型 (-1, 偏移 + 十六到十 (“30”), 最大血, , )  ' ' [[[[[00BBEA9C]+4]+2c]]+10]+294
内存_读双精度小数型 (-1, 偏移 + 十六到十 (“38”), 最大蓝, , )  ' ' [[[[[00BBEA9C]+4]+2c]]+10]+294


共享.写文本型 (0, 人物名称)
共享.写双精度小数型 (20, 血)
共享.写双精度小数型 (30, 最大血)
共享.写双精度小数型 (40, 蓝)
共享.写双精度小数型 (50, 最大蓝)

标签2.标题 = “人物名称:” + 人物名称
标签3.标题 = “血量:” + 到文本 (血) + “/” + 到文本 (最大血) + “  蓝量:” + 到文本 (蓝) + “/” + 到文本 (最大蓝)


善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
快速回复
限100 字节
批量上传需要先选择文件,再选择上传
 
上一个 下一个