• 1403阅读
  • 5回复

任鸟飞易语言外挂第2期 第17课验证码 [复制链接]

上一主题 下一主题
离线啊冲
 

只看楼主 倒序阅读 使用道具 楼主  发表于: 2016-09-06
任鸟飞2014 辅助培训班
外部群:239774259
第17课

我们在内存中 找到这个图片的地址=====》生成图片=====>提交打码平台====>返回验证码文本===>提交验证码CALL

XXXXXXX   123

XXXXXXX
...
...
...
xxxxxxx+yyyy

0BAD66BC   不对
135C552C    
rep     movs dword ptr es:[edi], dword ptr [esi]
1B1B9328

064352d0   06A80380   可能不大


[00BA6910]+38







善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
离线啊冲

只看该作者 沙发  发表于: 2016-09-06
.版本 2

.程序集 窗口程序集1
.程序集变量 大漠, 大漠中文版
.程序集变量 窗口句柄, 整数型
.程序集变量 x, 变体型
.程序集变量 y, 变体型

.子程序 __启动窗口_创建完毕

模块注册 ()
加载外挂作坊驱动 ()

时钟1.时钟周期 = 5000


.如果真 (大漠注册 (取运行目录 () + “\dm.dll”) = 真)
    大漠.创建对象 ()

.如果真结束


.子程序 _按钮1_被单击
.局部变量 m, 整数型
.局部变量 n, 整数型


进程_创建进程 (编辑框1.内容)
超级延时 (1000)

.循环判断首 ()

    窗口句柄 = 窗口_取窗口句柄 (, “QQ仙侠传登录程序”, 真)
    超级延时 (200)

.循环判断尾 (窗口句柄 = 0)  ' 窗口句柄=0 说明    窗口没有创建成功    窗口句柄!=0   创建成功


.循环判断首 ()

    大漠.找图 (0, 0, 2000, 2000, 取运行目录 () + “\开始游戏.bmp”, “101010”, 0.9, 0, x, y)
    超级延时 (200)

.循环判断尾 (x.取数值 () < 1)  ' x.取数值 () < 1   没有找到图片

大漠.移动鼠标 (x.取数值 (), y.取数值 ())
超级延时 (500)
大漠.左键单击 ()
超级延时 (1000)



.循环判断首 ()

    大漠.找图 (0, 0, 2000, 2000, 取运行目录 () + “\登陆游戏.bmp”, “101010”, 0.9, 0, x, y)
    超级延时 (200)

.循环判断尾 (x.取数值 () < 1)  ' x.取数值 () < 1   没有找到图片


.如果真 (x.取数值 () > 1)

    大漠.移动鼠标 (x.取数值 (), y.取数值 () - 135)
    超级延时 (200)
    大漠.左键单击 ()
    超级延时 (200)

    .计次循环首 (11, n)

        大漠.按键 (8)
        超级延时 (100)
    .计次循环尾 ()  ' '''''''''''''''''''''''删除已有的账号

    输出文本 (编辑框2.内容)

    大漠.按键 (9)
    超级延时 (200)

    输出文本 (编辑框3.内容)

    超级延时 (200)

    大漠.按键 (13)  ' ''''''''''''''''''回车
    超级延时 (2000)

.如果真结束



.子程序 _按钮2_被单击
.局部变量 窗口句柄1, 整数型



窗口句柄1 = 窗口_取窗口句柄 (, “QQ仙侠传”, 真)
标签1.标题 = 到文本 (窗口句柄1)

安装输入法DLL (窗口句柄1, “第二课.dll”)


.子程序 _时钟1_周期事件
.局部变量 人物名称, 文本型
.局部变量 共享, 类_共享内存
.局部变量 血, 双精度小数型
.局部变量 最大血, 双精度小数型
.局部变量 蓝, 双精度小数型
.局部变量 最大蓝, 双精度小数型
.局部变量 返回, 逻辑型


返回 = 共享.打开内存 (“共享内存”)

标签1.标题 = 到文本 (返回)

共享.读文本型 (0, 人物名称)
共享.读双精度小数型 (20, 血)
共享.读双精度小数型 (30, 最大血)
共享.读双精度小数型 (40, 蓝)
共享.读双精度小数型 (50, 最大蓝)

标签2.标题 = “人物名称:” + 人物名称
标签3.标题 = “血量:” + 到文本 (血) + “/” + 到文本 (最大血) + “  蓝量:” + 到文本 (蓝) + “/” + 到文本 (最大蓝)
善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
离线啊冲

只看该作者 板凳  发表于: 2016-09-06
.版本 2

.程序集 窗口程序集1
.程序集变量 共享, 类_共享内存
.程序集变量 返回, 逻辑型

.子程序 _窗口1_创建完毕

时钟1.时钟周期 = 5000
_时钟1_周期事件 ()
返回 = 共享.创建内存 (“共享内存”, 4096)
标签1.标题 = 到文本 (返回)

.子程序 _时钟1_周期事件
.局部变量 偏移, 整数型
.局部变量 人物名称, 文本型
.局部变量 血, 双精度小数型
.局部变量 蓝, 双精度小数型
.局部变量 最大血, 双精度小数型
.局部变量 最大蓝, 双精度小数型

内存_读整数型 (-1, 十六到十 (“00BBeA9C”), 偏移, , )  ' [00BBEA9C]
内存_读整数型 (-1, 偏移 + 十六到十 (“4”), 偏移, , )  ' [[00BBEA9C]+4]
内存_读整数型 (-1, 偏移 + 十六到十 (“2c”), 偏移, , )  ' [[[00BBEA9C]+4]+2c]
内存_读整数型 (-1, 偏移, 偏移, , )  ' [[[[00BBEA9C]+4]+2c]]
内存_读整数型 (-1, 偏移 + 十六到十 (“10”), 偏移, , )  ' ' [[[[[00BBEA9C]+4]+2c]]+10]

内存_读文本型 (-1, 偏移 + 十六到十 (“294”), 人物名称, , )  ' ' [[[[[00BBEA9C]+4]+2c]]+10]+294

内存_读双精度小数型 (-1, 偏移 + 十六到十 (“40”), 血, , )  ' ' [[[[[00BBEA9C]+4]+2c]]+10]+294
内存_读双精度小数型 (-1, 偏移 + 十六到十 (“48”), 蓝, , )  ' ' [[[[[00BBEA9C]+4]+2c]]+10]+294
内存_读双精度小数型 (-1, 偏移 + 十六到十 (“30”), 最大血, , )  ' ' [[[[[00BBEA9C]+4]+2c]]+10]+294
内存_读双精度小数型 (-1, 偏移 + 十六到十 (“38”), 最大蓝, , )  ' ' [[[[[00BBEA9C]+4]+2c]]+10]+294


共享.写文本型 (0, 人物名称)
共享.写双精度小数型 (20, 血)
共享.写双精度小数型 (30, 最大血)
共享.写双精度小数型 (40, 蓝)
共享.写双精度小数型 (50, 最大蓝)

标签2.标题 = “人物名称:” + 人物名称
标签3.标题 = “血量:” + 到文本 (血) + “/” + 到文本 (最大血) + “  蓝量:” + 到文本 (蓝) + “/” + 到文本 (最大蓝)


.子程序 _按钮1_被单击
.局部变量 验证码保存路径, 文本型
.局部变量 图片字节集, 字节集
.局部变量 图片号, 整数型
.局部变量 验证码偏移, 整数型

内存_读整数型 (-1, 十六到十 (“00BA6910”), 验证码偏移, , )
内存_读字节集 (-1, 验证码偏移 + 十六到十 (“38”), 图片字节集, 十六到十 (“600”), )
写到文件 (“C:\1.bmp”, 图片字节集)

善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
离线r175a

只看该作者 地板  发表于: 2016-12-02
真心感谢论坛的高手————为小白指引了方面……。
离线im86165507

只看该作者 4楼 发表于: 2017-09-15
有没教程
离线aandok

只看该作者 5楼 发表于: 02-18

A3 1C5A4500   mov     dword ptr [455A1C], eax
00402106   .  E8 059E
快速回复
限100 字节
如果您提交过一次失败了,可以用”恢复数据”来恢复帖子内容
 
上一个 下一个