刺激战场
  • 2430阅读
  • 23回复

任鸟飞第四期 [复制链接]

上一主题 下一主题
离线啊冲
 

只看楼主 倒序阅读 使用道具 楼主  发表于: 2016-09-08
— 本帖被 啊冲 执行加亮操作(2016-09-13) —
任鸟飞2014
QQ:313866957
第一课
0
新学期开课

1
内存
基地址
  静态地址--->全局变量
  动态地址--->[01014DD0]+118--->500000+118--->500118
01014DD0 地址  [01014DD0] 地址里面的值
指针

1    地图ID
2
3
4    
5    人血


2
CE
CE的界面
CE中查看代码
修改代码实现功能,例如使怪物攻击无效
查看代码详情 CE追基地址
添加指针
[[35E82B0]+280]+1C  P->
HOOK  D3D
善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
离线啊冲

只看该作者 沙发  发表于: 2016-09-08
任鸟飞2014
QQ:313866957

第4期第2课
地图编号为例练习CE

mov [esi+C],ecx
[esi+C]==ecx


1
2
3
4
5
...
...
esi+C   [esi+C]


ecx==10004 地图ID
esi+C=27283D40+C


[27283D40+C]==10004
[35e9d98]==27283D40


[[35e9d98]+C]  ==  地图ID号

原因
[35e9d98] 他会变化
善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
离线啊冲

只看该作者 板凳  发表于: 2016-09-08
8个寄存器
ESP EBP 堆栈寄存器
ESP  栈顶指针
EBP  栈低指针

EIP 指向我下一条要执行的代码

浮点栈

断点----硬件断点

运行

F7 和 F8
在遇见CALL的时候  F7 是进入  而F8 不进入CALL
善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
离线啊冲

只看该作者 地板  发表于: 2016-09-08
任鸟飞2014
第4期第7课---汇编基础
QQ:313866957

mov edx,[esi+4]          edx==[esi+4]
lea edx,[esi+4]          edx==esi+4     =========》 mov edx,esi+4
add ecx,C                ecx==ecx+C          
sub ecx,C                ecx==ecx-C

movzx ecx,ax      12345678   1111           ecx==00001111
eax 32位寄存器   ax   低16位    al ah


push  ebx
pop   ebX
CALL xxxxx     push eip  jmp xxxx  call eax
RETN  POP EIP

test al,al  判断AL 是否等于0
JMP  无条件跳转
CMP  比较的命令
JE  
JNZ

xor   异或   XOR EAX,EAX  清零    3 XOR 11    11 xor 1011 ==   1000 ==8
and   且      3 and 11   11 and  1011  ==  11 ==3
or    或    

fld  =====》push
fstp =====》 POP

inc edi    edi=edi+1
善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
离线啊冲

只看该作者 4楼 发表于: 2016-09-08
任鸟飞2014 YY公开课

任鸟飞2014辅助培训班 系列教程及相关辅导
网站:www.hifyl.com
QQ:313866957

堆栈基础


1 什么是堆栈
堆栈就是一种数据项按序排列的数据结构,只能在栈顶对数据项进行插入和删除
特点是 先进后出

2 堆栈指针寄存器

4个数据寄存器和2个数据指针寄存器
EIP  指令指针寄存器
ESP  栈顶指针  
EBP  栈低指针


3 改变堆栈的操作
PUSH EAX     sub esp,4    mov [esp],eax
POP  eax     mov eax,[esp]    add esp,4
call 1234   ==  push eip   jmp 1234
retn 8   == POP eip   ADD ESP,8
add esp,xxx
sub esp,xxx

4 堆栈中储存的都是 参数 局部变量 操作中间数
那么我们怎么去找他的来源
例如 [EBP-4]   [EBP+8]   [ESP+20]

[ebp+8]  第一参数
[ebp+C]  第二个参数
...
[ebp-4]  第一个局部变量
[ebp-8]  第一个局部变量
...

实例来说明
00D70F06  |.  E8 75FBFEFF     call    00D60A80
通过EBP  来传递参数 和局部变量

push    ebp
mov     ebp, esp
...
...
mov     esp, ebp
pop     ebp


0094670F  |.  E8 5C973C00   call    00D0FE70

009C0E2F  |.  E8 0CF13400   call    00D0FF40

通过ESP  来传递参数 和局部变量





善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
离线啊冲

只看该作者 5楼 发表于: 2016-09-08
实现了点击按钮
2种方法
1种找到选中控件的CALL
1种 到点击按钮CALL的内部  去找直接传递控件对象 实现点击事件的CALL

201  202 --->鼠标点击的这个过程 鼠标按下 鼠标抬起--->按钮触发这个事件--->内存登录
                          选中控件的东西          



04B9FE58 - 39 86 3C030000  - cmp [esi+0000033C],eax
04B9F6DD - 39 81 3C030000  - cmp [ecx+0000033C],eax
04B9F6E5 - 89 81 3C030000  - mov [ecx+0000033C],eax
    
善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
离线啊冲

只看该作者 6楼 发表于: 2016-09-08
第4期第10课
QQ:313866957
勇者大冒险
人物血量
dd [[[0af9184]+4]+104]+1C


0049542A - 8B 04 82   - mov eax,[edx+eax*4]
00495A1A - 8B 0C 91   - mov ecx,[ecx+edx*4]
00495A2B - 89 34 91   - mov [ecx+edx*4],esi

04822162 - 8B 4E 08  - mov ecx,[esi+08]
04822165 - 89 48 08  - mov [eax+08],ecx

00413437 - 39 94 81 40030000  - cmp [ecx+eax*4+00000340],edx
00413440 - 89 94 81 40030000  - mov [ecx+eax*4+00000340],edx



CALL  XXXXXX




XXXXXX     ....
XXXXXX     .....
xxxxxx     JMP   495410




495410    ecx ,ecx==12EB50F0
善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
离线啊冲

只看该作者 7楼 发表于: 2016-09-08
00827350   .  C2 0C00       retn    0C
00827353   .  8B36          mov     esi, dword ptr [esi]             ;  [esi]
遇见这种形式的地方
他不是函数的头部 就是被跳转来的
如果在上面下断第一句不是返回到  那么肯定不是函数头部
如果没有  跳转的代码
那么就应该是  JMp  eax*什么 +什么这样

dd [[[[[[0b4f214]+52*4]+30]+2*4]+8]+8




0012F9A4   09AD5750
0012F9A8  /0012F9C0
0012F9AC  |008255B4  返回到 YYC3D.008255B4 来自 YYC3D.00825490
0012F9B0  |00000025
0012F9B4  |0012F9C8
0012F9B8  |25FF5240
0012F9BC  |274CB7C8
0012F9C0  ]0012FA50
0012F9C4  |00493E7F  返回到 YYC3D.00493E7F 来自 YYC3D.008255A0
0012F9C8  |00000000
0012F9CC  |00000001
0012F9D0  |EBB69678
0012F9D4  |2837EC78
0012F9D8  |25FF5240
0012F9DC  |00000000
0012F9E0  |0012FA68
0012F9E4  |7C92E920  ntdll.7C92E920
0012F9E8  |7C930060  ntdll.7C930060
0012F9EC  |FFFFFFFF
0012F9F0  |7C93005D  返回到 ntdll.7C93005D 来自 ntdll.7C92E906
0012F9F4  |78AB016A  返回到 msvcr100.78AB016A 来自 ntdll.RtlFreeHeap
0012F9F8  |033A0000
0012F9FC  |00000000
0012FA00  |23DF74A0
0012FA04  |23DF76BC
0012FA08  |23DF76BC
0012FA0C  |24771D48
0012FA10  |EBB6965C
0012FA14  |7F7FFFFF
0012FA18  |1065A238
0012FA1C  |00000000
0012FA20  |00000000
0012FA24  |00000000
0012FA28  |0000003D
0012FA2C  |449DFB8F
0012FA30  |00AF90E8  YYC3D.00AF90E8
0012FA34  |4490359B
0012FA38  |40D5D94C
0012FA3C  |449DFB8F
0012FA40  |EBB69678
0012FA44  |0012FA70  指向下一个 SEH 记录的指针
0012FA48  |008D40FB  SE处理程序
0012FA4C  |00000000
0012FA50  ]0012FA7C
0012FA54  |005433D9  返回到 YYC3D.005433D9
0012FA58  |EBB69654
0012FA5C  |0048BE26  YYC3D.0048BE26
0012FA60  |00AF90E8  YYC3D.00AF90E8
0012FA64  |00000000
0012FA68  |00001340
0012FA6C  |0048BE26  YYC3D.0048BE26
0012FA70  |0012FA94  指向下一个 SEH 记录的指针
0012FA74  |008E6290  SE处理程序
0012FA78  |FFFFFFFF
0012FA7C  ]0012FAA0
0012FA80  |0044D2E0  返回到 YYC3D.0044D2E0 来自 YYC3D.00543320
0012FA84  |EBB69688
0012FA88  |0048BE26  YYC3D.0048BE26
0012FA8C  |00AC1850  YYC3D.00AC1850
0012FA90  |00000000
0012FA94  |0012FECC  指向下一个 SEH 记录的指针
0012FA98  |008CAB0C  SE处理程序
0012FA9C  |FFFFFFFF
0012FAA0  ]0012FED8
0012FAA4  |004024E0  返回到 YYC3D.004024E0 来自 YYC3D.0044D2A0
0012FAA8  |EBB692F0
0012FAAC  |0048BE26  YYC3D.0048BE26
0012FAB0  |00AC1850  YYC3D.00AC1850
0012FAB4  |00000000
0012FAB8  |00000000
0012FABC  |02980000
0012FAC0  |00000000
0012FAC4  |2454F110
0012FAC8  |00000000
0012FACC  |2417E7A8
0012FAD0  |040EE5EC  返回到 PixelScr.040EE5EC 来自 PixelScr.040C72F4
0012FAD4  |0012FD00
0012FAD8  |2454F118
0012FADC  |00000000



0011D524   FFFFFFFF
0011D528   0011D53C
0011D52C   269667D8
0011D530   25478BBE
0011D534   0011D554
0011D538   03FD9BDB  返回到 pg_guic.03FD9BDB 来自 msvcr100.memmove
0011D53C   0406F36C  pg_guic.0406F36C
0011D540   EBB5B96C
0011D544  /0011D560
0011D548  |00827422  返回到 YYC3D.00827422 来自 YYC3D.00827150
0011D54C  |09AD576C
0011D550  |00000001
0011D554  |114A45A4
0011D558  |00535FB0  YYC3D.00535FB0
0011D55C  |114A4548
0011D560  ]0011D570
0011D564  |00535FCD  返回到 YYC3D.00535FCD 来自 YYC3D.008273D0
0011D568  |00000002
0011D56C  |114A45A4
0011D570  ]0011D588
0011D574  |0408C0D3  返回到 PixelScr.0408C0D3
0011D578  |114A4624
0011D57C  |00000002
0011D580  |114A45A4
0011D584  |114A4624
0011D588  ]0011D5C8
0011D58C  |0408C704  返回到 PixelScr.0408C704 来自 PixelScr.0408C0B0
0011D590  |114A4624
0011D594  |114A4548
0011D598  |00000008
0011D59C  |00535FB0  YYC3D.00535FB0
0011D5A0  |0BEA3088
0011D5A4  |25548A18
0011D5A8  |114A4544
0011D5AC  |00000000
0011D5B0  |00000000
0011D5B4  |00000003
0011D5B8  |10996270
0011D5BC  |0000000A
0011D5C0  |10946A70
0011D5C4  |00000000
0011D5C8  ]0011D608
0011D5CC  |040A3F3F  返回到 PixelScr.040A3F3F 来自 PixelScr.0408C4C0
0011D5D0  |114A4624








0011D4F8   114A45A4
0011D4FC   09AD244A
0011D500  /0011D544
0011D504  |00827361  返回到 YYC3D.00827361 来自 YYC3D.0040F960
0011D508  |09AD244A
0011D50C  |00000002
0011D510  |114A45A4
0011D514  |09AD5764
0011D518  |269667C8
0011D51C  |0011D62C
0011D520  |04013CA8  pg_guic.04013CA8
0011D524  |FFFFFFFF
0011D528  |0011D53C
0011D52C  |269667D8
0011D530  |25478BBE
0011D534  |0011D554
0011D538  |03FD9BDB  返回到 pg_guic.03FD9BDB 来自 msvcr100.memmove
0011D53C  |0406F36C  pg_guic.0406F36C
0011D540  |EBB5B96C
0011D544  ]0011D560
0011D548  |00827422  返回到 YYC3D.00827422 来自 YYC3D.00827150
0011D54C  |09AD576C
0011D550  |00000001
0011D554  |114A45A4
0011D558  |00535FB0  YYC3D.00535FB0
0011D55C  |114A4548
0011D560  ]0011D570
0011D564  |00535FCD  返回到 YYC3D.00535FCD 来自 YYC3D.008273D0
0011D568  |00000002
0011D56C  |114A45A4
0011D570  ]0011D588
0011D574  |0408C0D3  返回到 PixelScr.0408C0D3
0011D578  |114A4624
0011D57C  |00000002
0011D580  |114A45A4
0011D584  |114A4624
0011D588  ]0011D5C8
0011D58C  |0408C704  返回到 PixelScr.0408C704 来自 PixelScr.0408C0B0
0011D590  |114A4624
0011D594  |114A4548
0011D598  |00000008
善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
离线啊冲

只看该作者 8楼 发表于: 2016-09-08
0012F9A4   09AD5750
0012F9A8  /0012F9C0
0012F9AC  |008255B4  返回到 YYC3D.008255B4 来自 YYC3D.00825490
0012F9B0  |00000025
0012F9B4  |0012F9C8
0012F9B8  |25FF5240
0012F9BC  |274CB7C8
0012F9C0  ]0012FA50
0012F9C4  |00493E7F  返回到 YYC3D.00493E7F 来自 YYC3D.008255A0
0012F9C8  |00000000
0012F9CC  |00000001
0012F9D0  |EBB69678
0012F9D4  |2837EC78
0012F9D8  |25FF5240
0012F9DC  |00000000
0012F9E0  |0012FA68
0012F9E4  |7C92E920  ntdll.7C92E920
0012F9E8  |7C930060  ntdll.7C930060
0012F9EC  |FFFFFFFF
0012F9F0  |7C93005D  返回到 ntdll.7C93005D 来自 ntdll.7C92E906
0012F9F4  |78AB016A  返回到 msvcr100.78AB016A 来自 ntdll.RtlFreeHeap
0012F9F8  |033A0000
0012F9FC  |00000000



52是我们追到的  这个 NPC 头部顶着的名称  具体这个数组里面都有什么   不是特别清楚 但是很多
dd [[[[[[00B4F214]+52*4]+30]+0*4]+8]+8]  名称的偏移

dd [[[00B4F214]+52*4]+30]+eax*4   根据eax 的不同  指向不同的对象

dd [[[00B4F214]+52*4]+30]  数组开始的位置

dd [[[00B4F214]+52*4]+34]  数组结束的位置
  
或则 在数组对象等于0的时候  数组结束

还有一种就是    +30这一层偏移里面  存在着一个  数组的数量



[[[[00B4F214]+340]+8]+8]

[[[[[[[00B4F214]+340]]]]+8]+8]







善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
离线啊冲

只看该作者 9楼 发表于: 2016-09-08
.版本 2

.程序集 窗口程序集1
.程序集变量 XX文本, 文本型
.程序集变量 窗口过程, 整数型

.子程序 _按钮_call_被单击, , , <<CALL线程>>

线程_创建线程 (&CALL)

.子程序 CALL, , , <<调用CALL>>




.子程序 各种公式, , , 记录各种公式

' [[[0af9184]+4]+104]+1C  人物血量
' [[[0af9184]+4]+104]+4   人物等级
' [[[0af9184]+4]+104]-28  人物名称
' [[[0af9184]+4]+104]-48  账号
' [[[[[[[0b4f214]+52*4]+30]+0*4]+8]+8]  NPC名称





.子程序 消息接口, 整数型
.参数 窗口句柄, 整数型
.参数 消息ID, 整数型
.参数 消息值1, 整数型
.参数 消息值2, 整数型


编辑框_遍历.加入文本 (“窗口句柄:” + 到文本 (窗口句柄) + “  消息ID:” + 到文本 (消息ID) + “  消息值:” + 到文本 (消息值1) + “,” + 到文本 (消息值2) + #换行符)


返回 (CallWindowProc (窗口过程, 窗口句柄, 消息ID, 消息值1, 消息值2))

.子程序 _按钮_主线程_被单击
.局部变量 窗口句柄, 整数型

窗口句柄 = 窗口_取窗口句柄 (“YYC3D.exe”, , )
窗口过程 = GetWindowLong (窗口句柄, -4)
SetWindowLong (窗口句柄, -4, &消息接口)  ' '''''''消息子类化(窗口句柄,&消息接口)





.子程序 _按钮_人物_被单击
.局部变量 基地址, 整数型
.局部变量 偏移, 整数型
.局部变量 人物血量, 整数型
.局部变量 人物等级, 整数型
.局部变量 人物名称, 文本型
.局部变量 人物账号, 文本型

基地址 = 内存_读整数型 (-1, 十六到十 (“0af9184”))
偏移 = 内存_读整数型 (-1, 基地址 + 十六到十 (“4”))
偏移 = 内存_读整数型 (-1, 偏移 + 十六到十 (“104”))
人物血量 = 内存_读整数型 (-1, 偏移 + 十六到十 (“1C”))
人物等级 = 内存_读整数型 (-1, 偏移 + 十六到十 (“4”))
人物名称 = 内存_读文本型 (-1, 偏移 - 十六到十 (“28”))
人物账号 = 内存_读文本型 (-1, 偏移 - 十六到十 (“48”))
编辑框_遍历.内容 = “账号:” + 人物账号 + “   ” + 人物名称 + “  等级:” + 到文本 (人物等级) + “   人物血量:” + 到文本 (人物血量) + #换行符


.子程序 _按钮_npc_被单击
.局部变量 基地址, 整数型
.局部变量 偏移, 整数型
.局部变量 开始位置, 整数型
.局部变量 结束位置, 整数型
.局部变量 数量, 整数型
.局部变量 n, 整数型
.局部变量 对象, 整数型
.局部变量 名称, 文本型
.局部变量 文本, 文本型

' [[[[[[[0b4f214]+52*4]+30]+0*4]+8]+8]  NPC名称

基地址 = 内存_读整数型 (-1, 十六到十 (“0b4f214”))
偏移 = 内存_读整数型 (-1, 基地址 + 十六到十 (“148”))
开始位置 = 内存_读整数型 (-1, 偏移 + 十六到十 (“30”))
结束位置 = 内存_读整数型 (-1, 偏移 + 十六到十 (“34”))
数量 = (结束位置 - 开始位置) ÷ 4


.计次循环首 (数量, n)
    .如果真 (指针_是否可读 (开始位置 + 十六到十 (“4”) × (n - 1)) = 真)
        对象 = 内存_读整数型 (-1, 开始位置 + 十六到十 (“4”) × (n - 1))
        .如果真 (指针_是否可读 (对象 + 十六到十 (“8”)) = 真)
            对象 = 内存_读整数型 (-1, 对象 + 十六到十 (“8”))
            .如果真 (指针_是否可读 (对象 + 十六到十 (“8”)) = 真)
                对象 = 内存_读整数型 (-1, 对象 + 十六到十 (“8”))
                .如果真 (指针_是否可读 (对象 + 十六到十 (“0”)) = 真)
                    名称 = 内存_读文本型 (-1, 对象 + 十六到十 (“0”))
                    文本 = 文本 + 名称 + #换行符

                .如果真结束

            .如果真结束

        .如果真结束

    .如果真结束

.计次循环尾 ()


编辑框_遍历.内容 = 文本



善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
离线啊冲

只看该作者 10楼 发表于: 2016-09-08
.版本 2

.程序集 窗口程序集1
.程序集变量 进程ID, 整数型
.程序集变量 线程ID, 整数型
.程序集变量 文件名, 文本型
.程序集变量 钩子注入线程ID, 整数型
.程序集变量 钩子句柄, 整数型

.子程序 __启动窗口_创建完毕




.子程序 _按钮_线程注入_被单击


.如果真 (进程ID = 0 且 线程ID = 0)

    .如果真 (通用对话框1.打开 () = 真)
        文件名 = 通用对话框1.文件名
        进程_提升进程权限2 ()
        窗口_取进程线程ID (窗口_取窗口句柄 (“YYC3D.exe”), 进程ID, 线程ID)
        .如果真 (进程ID ≠ 0 且 线程ID ≠ 0)
            注入_线程注入dll (进程ID, 线程ID, 通用对话框1.文件名)
        .如果真结束

    .如果真结束

.如果真结束



.子程序 _按钮_卸载线程注入_被单击

.如果真 (进程ID ≠ 0 且 线程ID ≠ 0)
    注入_线程dll卸载 (进程ID, 线程ID, 文件名)
    进程ID = 0
    线程ID = 0
.如果真结束





.子程序 _按钮_注入_被单击

.如果真 (通用对话框1.打开 () = 真)
    窗口_取进程线程ID (窗口_取窗口句柄 (“YYC3D.exe”), 进程ID, 钩子注入线程ID)
    .如果真 (钩子注入线程ID > 0)
        钩子句柄 = 注入_钩子注入dll (通用对话框1.文件名, 钩子注入线程ID)

    .如果真结束


.如果真结束


.子程序 _按钮_卸载_被单击

注入_钩子dll卸载 (钩子句柄)
善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
离线啊冲

只看该作者 11楼 发表于: 2016-09-08
明文发包特征码


008C0200  /$  55            push    ebp
008C0201  |.  8BEC          mov     ebp, esp
008C0203  |.  81EC 0C040000 sub     esp, 40C
008C0209  |.  A1 80F6AB00   mov     eax, dword ptr [ABF680]
008C020E  |.  33C5          xor     eax, ebp
008C0210  |.  8945 FC       mov     dword ptr [ebp-4], eax
008C0213  |.  53            push    ebx
008C0214  |.  56            push    esi
008C0215  |.  8B75 0C       mov     esi, dword ptr [ebp+C]
008C0218  |.  8BD9          mov     ebx, ecx
008C021A  |.  80BB 35010000>cmp     byte ptr [ebx+135], 0
008C0221  |.  57            push    edi
008C0222  |.  8B7D 08       mov     edi, dword ptr [ebp+8]
008C0225  |.  74 2F         je      short 008C0256
008C0227  |.  8BC6          mov     eax, esi
008C0229  |.  83FE 40       cmp     esi, 40
008C022C  |.  72 05         jb      short 008C0233
008C022E  |.  B8 40000000   mov     eax, 40
008C0233  |>  6A 01         push    1
008C0235  |.  6A 01         push    1
008C0237  |.  8D8D FCFBFFFF lea     ecx, dword ptr [ebp-404]
008C023D  |.  51            push    ecx
008C023E  |.  50            push    eax
008C023F  |.  57            push    edi
008C0240  |.  E8 1BE9EAFF   call    0076EB60
008C0245  |.  50            push    eax
008C0246  |.  56            push    esi
008C0247  |.  68 CC839E00   push    009E83CC                          ;  ASCII ",TEMP,CNL _Send_DATA_Safe,%d,%s"
008C024C  |.  6A 00         push    0
008C024E  |.  E8 FD32EFFF   call    007B3550
008C0253  |.  83C4 24       add     esp, 24
008C0256  |>  81FE F9030000 cmp     esi, 3F9
008C025C  |.  0F87 8F000000 ja      008C02F1
008C0262  |.  8B93 440D0000 mov     edx, dword ptr [ebx+D44]
008C0268  |.  8B42 1C       mov     eax, dword ptr [edx+1C]
008C026B  |.  0FB748 1A     movzx   ecx, word ptr [eax+1A]
008C026F  |.  0FB750 14     movzx   edx, word ptr [eax+14]
008C0273  |.  2BCA          sub     ecx, edx
008C0275  |.  75 4B         jnz     short 008C02C2
008C0277  |.  388B 35010000 cmp     byte ptr [ebx+135], cl
008C027D  |.  74 2D         je      short 008C02AC
008C027F  |.  8BC6          mov     eax, esi
008C0281  |.  83FE 40       cmp     esi, 40
008C0284  |.  72 03         jb      short 008C0289
008C0286  |.  8D41 40       lea     eax, dword ptr [ecx+40]
008C0289  |>  6A 01         push    1
008C028B  |.  6A 01         push    1
008C028D  |.  8D8D FCFBFFFF lea     ecx, dword ptr [ebp-404]
008C0293  |.  51            push    ecx
008C0294  |.  50            push    eax
008C0295  |.  57            push    edi
008C0296  |.  E8 C5E8EAFF   call    0076EB60
008C029B  |.  50            push    eax
008C029C  |.  56            push    esi
008C029D  |.  68 B4839E00   push    009E83B4                          ;  ASCII ",TEMP,CNL LOST,%d,%s"
008C02A2  |.  6A 00         push    0
008C02A4  |.  E8 A732EFFF   call    007B3550
008C02A9  |.  83C4 24       add     esp, 24
008C02AC  |>  5F            pop     edi
008C02AD  |.  5E            pop     esi
008C02AE  |.  83C8 FF       or      eax, FFFFFFFF
008C02B1  |.  5B            pop     ebx
008C02B2  |.  8B4D FC       mov     ecx, dword ptr [ebp-4]
008C02B5  |.  33CD          xor     ecx, ebp
008C02B7  |.  E8 C64EFAFF   call    00865182
008C02BC  |.  8BE5          mov     esp, ebp
008C02BE  |.  5D            pop     ebp
008C02BF  |.  C2 0C00       retn    0C
008C02C2  |>  8B55 10       mov     edx, dword ptr [ebp+10]
008C02C5  |.  52            push    edx
008C02C6  |.  6A 00         push    0
008C02C8  |.  56            push    esi
008C02C9  |.  57            push    edi
008C02CA  |.  8BCB          mov     ecx, ebx
008C02CC  |.  E8 6FFDFFFF   call    008C0040                          ;  明文发包CALL
008C02D1  |.  33C9          xor     ecx, ecx
008C02D3  |.  85C0          test    eax, eax
008C02D5  |.  0F99C1        setns   cl
008C02D8  |.  5F            pop     edi
008C02D9  |.  5E            pop     esi
008C02DA  |.  5B            pop     ebx
008C02DB  |.  8D41 FF       lea     eax, dword ptr [ecx-1]
008C02DE  |.  83E0 FE       and     eax, FFFFFFFE
008C02E1  |.  8B4D FC       mov     ecx, dword ptr [ebp-4]
008C02E4  |.  33CD          xor     ecx, ebp
008C02E6  |.  E8 974EFAFF   call    00865182
008C02EB  |.  8BE5          mov     esp, ebp
008C02ED  |.  5D            pop     ebp
008C02EE  |.  C2 0C00       retn    0C
008C02F1  |>  B8 B38AE180   mov     eax, 80E18AB3
008C02F6  |.  F7EE          imul    esi
008C02F8  |.  03D6          add     edx, esi
008C02FA  |.  C1FA 09       sar     edx, 9
008C02FD  |.  8BC2          mov     eax, edx
008C02FF  |.  C1E8 1F       shr     eax, 1F
008C0302  |.  03C2          add     eax, edx
008C0304  |.  8BD0          mov     edx, eax
008C0306  |.  69D2 F9030000 imul    edx, edx, 3F9
008C030C  |.  8BCE          mov     ecx, esi
008C030E  |.  2BCA          sub     ecx, edx
008C0310  |.  898D F4FBFFFF mov     dword ptr [ebp-40C], ecx
008C0316  |.  B9 00000000   mov     ecx, 0
008C031B  |.  0F95C1        setne   cl
008C031E  |.  03C8          add     ecx, eax
008C0320  |.  8B83 440D0000 mov     eax, dword ptr [ebx+D44]
008C0326  |.  8B40 1C       mov     eax, dword ptr [eax+1C]
008C0329  |.  0FB750 1A     movzx   edx, word ptr [eax+1A]
008C032D  |.  0FB740 14     movzx   eax, word ptr [eax+14]
008C0331  |.  2BD0          sub     edx, eax
008C0333  |.  898D F8FBFFFF mov     dword ptr [ebp-408], ecx
008C0339  |.  3BCA          cmp     ecx, edx
008C033B  |.  7E 50         jle     short 008C038D
008C033D  |.  80BB 35010000>cmp     byte ptr [ebx+135], 0
008C0344  |.  74 2F         je      short 008C0375
008C0346  |.  8BC6          mov     eax, esi
008C0348  |.  83FE 40       cmp     esi, 40
008C034B  |.  72 05         jb      short 008C0352
008C034D  |.  B8 40000000   mov     eax, 40
008C0352  |>  6A 01         push    1
008C0354  |.  6A 01         push    1
008C0356  |.  8D8D FCFBFFFF lea     ecx, dword ptr [ebp-404]
008C035C  |.  51            push    ecx
008C035D  |.  50            push    eax
008C035E  |.  57            push    edi
008C035F  |.  E8 FCE7EAFF   call    0076EB60
善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
离线啊冲

只看该作者 12楼 发表于: 2016-09-08
第4期第15课
周围玩家二叉树


00548A00 - 8A 18  - mov bl,[eax]
00548A52 - 3A 1A  - cmp bl,[edx]
00548B56 - 8A 19  - mov bl,[ecx]


0059A793 - 8A 08  - mov cl,[eax]
0277C3E3 - 0FB6 0F  - movzx ecx,byte ptr [edi]
0277C409 - 8A 09  - mov cl,[ecx]
051B6E52 - 8A 08  - mov cl,[eax]
7C84C3E3 - 0FB6 0F  - movzx ecx,byte ptr [edi]
7C84C409 - 8A 09  - mov cl,[ecx]



0045672E  |.  8B4E 10       mov     ecx, dword ptr [esi+10]          ;  

dd [[[[0AF9170]+1D8+4]+4]]+C


二叉树根

005439DE  |.  E8 9DB5ECFF   call    0040EF80
005439E3  |.  895D FC       mov     dword ptr [ebp-4], ebx
005439E6  |.  8B7D C8       mov     edi, dword ptr [ebp-38]
005439E9  |.  8D45 D4       lea     eax, dword ptr [ebp-2C]
005439EC  |.  50            push    eax
005439ED  |.  8D4D CC       lea     ecx, dword ptr [ebp-34]
005439F0  |.  51            push    ecx
005439F1  |.  8D8F D8010000 lea     ecx, dword ptr [edi+1D8]         ;  dd [[ecx+4]+4]+C
005439F7  |.  E8 B44F0000   call    005489B0
005439FC  |.  8B55 D0       mov     edx, dword ptr [ebp-30]
005439FF  |.  8B45 CC       mov     eax, dword ptr [ebp-34]
00543A02  |.  52            push    edx


二叉树
005489B0  /$  55            push    ebp                              ;  dd [[ecx+4]+4]+C
005489B1  |.  8BEC          mov     ebp, esp
005489B3  |.  83EC 10       sub     esp, 10
005489B6  |.  8B41 04       mov     eax, dword ptr [ecx+4]
005489B9  |.  53            push    ebx
005489BA  |.  56            push    esi
005489BB  |.  57            push    edi
005489BC  |.  8B78 04       mov     edi, dword ptr [eax+4]
005489BF  |.  807F 2D 00    cmp     byte ptr [edi+2D], 0
005489C3  |.  8BD0          mov     edx, eax
005489C5  |.  894D F0       mov     dword ptr [ebp-10], ecx
005489C8  |.  8945 F4       mov     dword ptr [ebp-C], eax
005489CB  |.  8955 FC       mov     dword ptr [ebp-4], edx
005489CE  |.  0F85 BD000000 jnz     00548A91
005489D4  |.  8B55 0C       mov     edx, dword ptr [ebp+C]
005489D7  |.  8B42 14       mov     eax, dword ptr [edx+14]
005489DA  |.  8945 F8       mov     dword ptr [ebp-8], eax           ;  edi+C 不会变化了
005489DD  |.  EB 04         jmp     short 005489E3
005489DF  |   90            nop                                      ;  nop
005489E0  |>  8B55 0C       mov     edx, dword ptr [ebp+C]           ;  跳转来的地方
005489E3  |>  837D F8 10    cmp     dword ptr [ebp-8], 10
005489E7  |.  72 02         jb      short 005489EB
005489E9  |.  8B12          mov     edx, dword ptr [edx]
005489EB  |>  8B4F 20       mov     ecx, dword ptr [edi+20]
005489EE  |.  83F9 10       cmp     ecx, 10
005489F1  |.  72 05         jb      short 005489F8
005489F3  |.  8B47 0C       mov     eax, dword ptr [edi+C]
005489F6  |.  EB 08         jmp     short 00548A00
005489F8  |>  8D47 0C       lea     eax, dword ptr [edi+C]           ;  edi+C
005489FB  |.  EB 03         jmp     short 00548A00
005489FD  |   8D49 00       lea     ecx, dword ptr [ecx]
00548A00  |>  8A18          /mov     bl, byte ptr [eax]              ;  eax 会变化
善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
离线啊冲

只看该作者 13楼 发表于: 2016-09-08
.版本 2

.程序集 窗口程序集1
.程序集变量 XX文本, 文本型
.程序集变量 窗口过程, 整数型

.子程序 _按钮_call_被单击, , , <<CALL线程>>

线程_创建线程 (&CALL)

.子程序 CALL, , , <<调用CALL>>




.子程序 各种公式, , , 记录各种公式

' [[[0af9184]+4]+104]+1C  人物血量
' [[[0af9184]+4]+104]+4   人物等级
' [[[0af9184]+4]+104]-28  人物名称
' [[[0af9184]+4]+104]-48  账号
' [[[[[[[0b4f214]+52*4]+30]+0*4]+8]+8]  NPC名称





.子程序 消息接口, 整数型
.参数 窗口句柄, 整数型
.参数 消息ID, 整数型
.参数 消息值1, 整数型
.参数 消息值2, 整数型


编辑框_遍历.加入文本 (“窗口句柄:” + 到文本 (窗口句柄) + “  消息ID:” + 到文本 (消息ID) + “  消息值:” + 到文本 (消息值1) + “,” + 到文本 (消息值2) + #换行符)


返回 (CallWindowProc (窗口过程, 窗口句柄, 消息ID, 消息值1, 消息值2))

.子程序 _按钮_主线程_被单击
.局部变量 窗口句柄, 整数型

窗口句柄 = 窗口_取窗口句柄 (“YYC3D.exe”, , )
窗口过程 = GetWindowLong (窗口句柄, -4)
SetWindowLong (窗口句柄, -4, &消息接口)  ' '''''''消息子类化(窗口句柄,&消息接口)





.子程序 _按钮_人物_被单击
.局部变量 基地址, 整数型
.局部变量 偏移, 整数型
.局部变量 人物血量, 整数型
.局部变量 人物等级, 整数型
.局部变量 人物名称, 文本型
.局部变量 人物账号, 文本型

基地址 = 内存_读整数型 (-1, 十六到十 (“0af9184”))
偏移 = 内存_读整数型 (-1, 基地址 + 十六到十 (“4”))
偏移 = 内存_读整数型 (-1, 偏移 + 十六到十 (“104”))
人物血量 = 内存_读整数型 (-1, 偏移 + 十六到十 (“1C”))
人物等级 = 内存_读整数型 (-1, 偏移 + 十六到十 (“4”))
人物名称 = 内存_读文本型 (-1, 偏移 - 十六到十 (“28”))
人物账号 = 内存_读文本型 (-1, 偏移 - 十六到十 (“48”))
编辑框_遍历.内容 = “账号:” + 人物账号 + “   ” + 人物名称 + “  等级:” + 到文本 (人物等级) + “   人物血量:” + 到文本 (人物血量) + #换行符


.子程序 _按钮_npc_被单击


线程_创建线程 (&遍历NPC模型)


.子程序 遍历NPC模型
.局部变量 基地址, 整数型
.局部变量 偏移, 整数型
.局部变量 开始位置, 整数型
.局部变量 结束位置, 整数型
.局部变量 数量, 整数型
.局部变量 n, 整数型
.局部变量 对象, 整数型
.局部变量 名称, 文本型
.局部变量 文本, 文本型

' [[[[[[[0b4f214]+52*4]+30]+0*4]+8]+8]  NPC名称

基地址 = 内存_读整数型 (-1, 十六到十 (“0b4f214”))
偏移 = 内存_读整数型 (-1, 基地址 + 十六到十 (“148”))
开始位置 = 内存_读整数型 (-1, 偏移 + 十六到十 (“30”))
结束位置 = 内存_读整数型 (-1, 偏移 + 十六到十 (“34”))
数量 = (结束位置 - 开始位置) ÷ 4

文本 = 到文本 (数量) + #换行符
.计次循环首 (数量, n)
    .如果真 (指针_是否可读 (开始位置 + 十六到十 (“4”) × (n - 1)) = 真)
        对象 = 内存_读整数型 (-1, 开始位置 + 十六到十 (“4”) × (n - 1))
        .如果真 (指针_是否可读 (对象 + 十六到十 (“8”)) = 真)
            对象 = 内存_读整数型 (-1, 对象 + 十六到十 (“8”))
            .如果真 (指针_是否可读 (对象 + 十六到十 (“8”)) = 真)
                对象 = 内存_读整数型 (-1, 对象 + 十六到十 (“8”))
                .如果真 (指针_是否可读 (对象 + 十六到十 (“0”)) = 真)
                    名称 = 内存_读文本型 (-1, 对象 + 十六到十 (“0”))
                    文本 = 文本 + 名称 + #换行符

                .如果真结束

            .如果真结束

        .如果真结束

    .如果真结束

.计次循环尾 ()


编辑框_遍历.内容 = 文本


.子程序 _按钮_NPC2_被单击
.局部变量 基地址, 整数型
.局部变量 偏移, 整数型
.局部变量 根节点, 整数型

基地址 = 内存_读整数型 (-1, 十六到十 (“0AF9170”))
偏移 = 内存_读整数型 (-1, 基地址 + 十六到十 (“1D8”) + 4)
根节点 = 内存_读整数型 (-1, 偏移 + 4)
XX文本 = “”
NPC遍历 (根节点)
编辑框_遍历.内容 = XX文本

.子程序 NPC遍历
.参数 根节点, 整数型
.局部变量 左子树, 整数型
.局部变量 右子树, 整数型
.局部变量 标志位, 字节型
.局部变量 名称, 文本型

左子树 = 内存_读整数型 (-1, 根节点 + 0)
右子树 = 内存_读整数型 (-1, 根节点 + 8)
标志位 = 内存_读字节型 (-1, 根节点 + 十六到十 (“2D”))
名称 = 内存_读文本型 (-1, 根节点 + 十六到十 (“C”))

.如果真 (名称 ≠ “”)
    XX文本 = XX文本 + 名称 + #换行符
.如果真结束


.如果真 (标志位 = 0)
    NPC遍历 (左子树)
    NPC遍历 (右子树)

.如果真结束
善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
离线啊冲

只看该作者 14楼 发表于: 2016-09-08
第4期课17课
年前会放一期课程
这个课程
购买2期课程以上的学员 都可以免费观看
系统化讲解  其他人购买699
第4期课程
后面重点
线程发包
控件 等等

年末编程课程
QQ仙侠传源码+更新数据+一套专门讲解代码的教程==2000元   限15人开课
外部学员不二价
内部学员2期的 7折  3期以上的6折
只想发展找数据的学员  无需购买

切记源码不要乱放!!! 伤人伤己


0063763B - 01 78 04  - add [eax+04],edi    [eax+4]=[eax+4]+EDI

00632C90 - 8B 41 2C  - mov eax,[ecx+2C]
0069C2A2 - 8B 47 2C  - mov eax,[edi+2C]
006330E0 - 8B 1A  - mov ebx,[edx]
00637E3E - 39 7E 2C  - cmp [esi+2C],edi
00637E81 - 2B 7E 2C  - sub edi,[esi+2C]
00637E88 - 89 46 2C  - mov [esi+2C],eax



dd [[[0b4a384]+38+4]+4]+14




00645F10  /$  55            push    ebp                              ;  [[ecx+4]+4]+14
00645F11  |.  8BEC          mov     ebp, esp
00645F13  |.  83EC 0C       sub     esp, 0C
00645F16  |.  56            push    esi
00645F17  |.  8BF1          mov     esi, ecx
00645F19  |.  8B4E 04       mov     ecx, dword ptr [esi+4]
00645F1C  |.  8B41 04       mov     eax, dword ptr [ecx+4]
00645F1F  |.  8078 19 00    cmp     byte ptr [eax+19], 0
00645F23  |.  57            push    edi
00645F24  |.  8BF9          mov     edi, ecx
00645F26  |.  8B4D 08       mov     ecx, dword ptr [ebp+8]
00645F29  |.  75 19         jnz     short 00645F44
00645F2B  |.  8B11          mov     edx, dword ptr [ecx]
00645F2D  |.  8D49 00       lea     ecx, dword ptr [ecx]
00645F30  |>  3950 0C       /cmp     dword ptr [eax+C], edx          ;  ID
00645F33  |.  7D 05         |jge     short 00645F3A
00645F35  |.  8B40 08       |mov     eax, dword ptr [eax+8]          ;  [[[eax+8]]+8]+14
00645F38  |.  EB 04         |jmp     short 00645F3E
00645F3A  |>  8BF8          |mov     edi, eax                        ;  eax+14
00645F3C  |.  8B00          |mov     eax, dword ptr [eax]
00645F3E  |>  8078 19 00    |cmp     byte ptr [eax+19], 0            ;  [eax+19]!=0
00645F42  |.^ 74 EC         \je      short 00645F30                  ;  JE 不实现跳转
00645F44  |>  3B7E 04       cmp     edi, dword ptr [esi+4]
00645F47  |.  74 07         je      short 00645F50
00645F49  |.  8B01          mov     eax, dword ptr [ecx]
00645F4B  |.  3B47 0C       cmp     eax, dword ptr [edi+C]
00645F4E  |.  7D 33         jge     short 00645F83
00645F50  |>  8B09          mov     ecx, dword ptr [ecx]
00645F52  |.  33C0          xor     eax, eax
00645F54  |.  8D55 F4       lea     edx, dword ptr [ebp-C]
00645F57  |.  894D F4       mov     dword ptr [ebp-C], ecx
00645F5A  |.  52            push    edx
00645F5B  |.  8BCE          mov     ecx, esi
00645F5D  |.  8945 F8       mov     dword ptr [ebp-8], eax
00645F60  |.  8945 FC       mov     dword ptr [ebp-4], eax
00645F63  |.  E8 88EFFFFF   call    00644EF0
00645F68  |.  50            push    eax
00645F69  |.  57            push    edi
00645F6A  |.  8D45 08       lea     eax, dword ptr [ebp+8]
00645F6D  |.  50            push    eax
00645F6E  |.  8BCE          mov     ecx, esi
00645F70  |.  E8 0BE0FFFF   call    00643F80
00645F75  |.  8B45 08       mov     eax, dword ptr [ebp+8]
00645F78  |.  5F            pop     edi
00645F79  |.  83C0 10       add     eax, 10
00645F7C  |.  5E            pop     esi
00645F7D  |.  8BE5          mov     esp, ebp
00645F7F  |.  5D            pop     ebp
00645F80  |.  C2 0400       retn    4
00645F83  |>  8D47 10       lea     eax, dword ptr [edi+10]          ;  edi+14
00645F86  |.  5F            pop     edi
00645F87  |.  5E            pop     esi
00645F88  |.  8BE5          mov     esp, ebp
00645F8A  |.  5D            pop     ebp                              ;  eax==edi+10
00645F8B  \.  C2 0400       retn    4
善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
离线啊冲

只看该作者 15楼 发表于: 2016-09-08
[[esp+8]]!=2
仅有同学问的问题


后面的课程
会主要找2款游戏
讲讲线程发包
控件
LUA
相关的知识


第5期的课程是  针对内部2期以及2期以上学员的免费课程
到时候会补充一些知识
那么2014数据全套教程就结束

12月会有一期代码课程  前面课程已经介绍(限15人开课)
善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
离线啊冲

只看该作者 16楼 发表于: 2016-09-08
动态加载模块



PUSH eax
push ebx
call  xxxx  

1940B2C  e8 6D53F0FF  CALL  xxxxx
1940B31
1940b31-1940b2c==5

6D 53 F0 FF
FFF0536d  偏移


1940b2c+fff0536D+5==1845e9e


xxxxx==1845e9e

1610000

1845e9e-1610000==235E9E(相对偏移)

模块_取模块句柄("3DROLE.dll")+十六到十("235E9E")



感谢SUMMER 同学提供64位图片
善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
离线啊冲

只看该作者 17楼 发表于: 2016-09-08
线程
启动线程()
创建线程()

判断是否进入战斗状态---->开启线程--->吃药的线程---判断自己的血量--->进行吃药的一个动作

判断是否进入战斗状态---->转向线程--->不断的面相离我们距离最近的怪物

时钟和线程



线程发包

发包线程--->判断是否需要发包--->调用发包CALL


.版本 2

a = 1
.判断循环首 (a = 1)
    超级延时 (20)
    共享.读文本型 (0, 命令)

    .如果真 (命令 = “瞬移”)
        共享.读整数型 (30, X)
        共享.读整数型 (40, Y)
        共享.读整数型 (50, H)
        共享.写文本型 (0, “”)
        共享.写整数型 (30, 0)
        共享.写整数型 (40, 0)
        共享.写整数型 (50, 0)
        坐标.X = X
        坐标.Y = Y
        坐标.H = H
        瞬移 (坐标)
    .如果真结束
    .如果真 (命令 = “血量”)
        共享.写文本型 (0, “”)
        返回文本 = 返回血量 ()
        .如果 (返回文本 ≠ “”)
            共享.写文本型 (100, 返回文本)
        .否则
            共享.写文本型 (100, “失败”)

.判断循环尾
善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
离线啊冲

只看该作者 18楼 发表于: 2016-09-08
注入的一些知识
和EXE和DLL的通信

有保护的游戏   我们用EXE 不可以直接读写内存 和CALL
用DLL注入以后  才能去做这些事

共享    类_共享内存


DLL注入到游戏内部以后
他要创建一个共享内存    
共享.创建内存 (“111111”, 4096)


EXE 通过共享内存的名称去调用他

.版本 2

.子程序 返回人物血量, 文本型
.局部变量 人物血量, 文本型

.如果真 (共享.打开内存 (“111111”))
    共享.写文本型 (0, “血量”)

    共享.读文本型 (100, 人物血量)
    .判断循环首 (人物血量 = “”)
        超级延时 (20)
        共享.读文本型 (100, 人物血量)
    .判断循环尾 ()
    共享.写文本型 (100, “”)
    返回 (人物血量)

.如果真结束
返回 (“共享内存不存在”)




.版本 2

    .如果真 (命令 = “血量”)
        共享.写文本型 (0, “”)
        返回文本 = 返回血量 ()
        .如果 (返回文本 ≠ “”)
            共享.写文本型 (100, 返回文本)
        .否则
            共享.写文本型 (100, “失败”)



注入的问题
把我们的DLL 塞入到游戏内部中去   获得游戏进程的所有的权限
钩子注入  
线程注入
输入法注入
内存注入
劫持注入
APC注入
....
...

连环注入
创建进程 (编辑框_路径.内容, , , 假, , 取运行目录 () + “\mydll.dll”)
善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
离线啊冲

只看该作者 19楼 发表于: 2016-09-08
防检测
1.
CALL 要主线程调用 ------>导致游戏崩溃
2.
写内存 主线程调用------>导致封号 或则游戏崩溃
3.
CALL  调用尽量最外层的功能CALL  或则是发包CALL
CALL1---》CALL2--->call3----》CALL4--->明文发包
全局变量  Num=99


xxxxx
...
...
...
mov  [12345678],0x99
...
...
...
...
CALL2----》...--->发包
...
...
...
RETN
4.
检测EXE
进程名
标题
隐藏进程()

5.
检测DLL
隐藏DLL()  无模块
隐藏模块 (-1, 取模块句柄 (“mydll.dll”), 假)


6.
检测特征码---修改界面  修改名称  修改一些关键代码

7.
特殊的检测
需要你对游戏有了解才能处理掉的

善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
快速回复
限100 字节
如果您提交过一次失败了,可以用”恢复数据”来恢复帖子内容
 
上一个 下一个