刺激战场
六合彩
贵宾厅
  • 1834阅读
  • 0回复

易语言远程CALL调用(API) [复制链接]

上一主题 下一主题
离线啊冲
 

只看楼主 倒序阅读 使用道具 楼主  发表于: 2016-11-29
.版本 2

.子程序 选择游戏窗口
.参数 序号, 整数型
.局部变量 打开句柄, 整数型
.局部变量 数据指针, 整数型
.局部变量 写出长度, 整数型
.局部变量 分配内存, 整数型
.局部变量 代码集, 字节集
.局部变量 线程句柄, 整数型

' pushad
' mov eax,00568000h
' mov eax,[eax]
' add eax,00000000h
' mov eax,[eax]
' mov ecx,00499EC0h
' call ecx
' popad
' ret

.判断开始 (到整数 (编辑框_窗口.内容) = 1)
    代码集 = { 96, 184, 0, 128, 86, 0, 139, 0, 131, 192, 0, 139, 0, 185, 192, 158, 73, 0, 255, 209, 97, 195 }
.判断 (到整数 (编辑框_窗口.内容) = 2)
    代码集 = { 96, 184, 0, 128, 86, 0, 139, 0, 131, 192, 4, 139, 0, 185, 192, 158, 73, 0, 255, 209, 97, 195 }
.判断 (到整数 (编辑框_窗口.内容) = 3)
    代码集 = { 96, 184, 0, 128, 86, 0, 139, 0, 131, 192, 8, 139, 0, 185, 192, 158, 73, 0, 255, 209, 97, 195 }
.判断 (到整数 (编辑框_窗口.内容) = 4)
    代码集 = { 96, 184, 0, 128, 86, 0, 139, 0, 131, 192, 12, 139, 0, 185, 192, 158, 73, 0, 255, 209, 97, 195 }
.判断 (到整数 (编辑框_窗口.内容) = 5)
    代码集 = { 96, 184, 0, 128, 86, 0, 139, 0, 131, 192, 16, 139, 0, 185, 192, 158, 73, 0, 255, 209, 97, 195 }
.判断 (到整数 (编辑框_窗口.内容) = 6)
    代码集 = { 96, 184, 0, 128, 86, 0, 139, 0, 131, 192, 20, 139, 0, 185, 192, 158, 73, 0, 255, 209, 97, 195 }
.判断 (到整数 (编辑框_窗口.内容) = 7)
    代码集 = { 96, 184, 0, 128, 86, 0, 139, 0, 131, 192, 24, 139, 0, 185, 192, 158, 73, 0, 255, 209, 97, 195 }
.判断 (到整数 (编辑框_窗口.内容) = 8)
    代码集 = { 96, 184, 0, 128, 86, 0, 139, 0, 131, 192, 28, 139, 0, 185, 192, 158, 73, 0, 255, 209, 97, 195 }
.判断 (到整数 (编辑框_窗口.内容) = 9)
    代码集 = { 96, 184, 0, 128, 86, 0, 139, 0, 131, 192, 32, 139, 0, 185, 192, 158, 73, 0, 255, 209, 97, 195 }
.判断 (到整数 (编辑框_窗口.内容) = 10)
    代码集 = { 96, 184, 0, 128, 86, 0, 139, 0, 131, 192, 36, 139, 0, 185, 192, 158, 73, 0, 255, 209, 97, 195 }
.判断 (到整数 (编辑框_窗口.内容 )> 10)
    返回 ()
.默认

.判断结束

打开句柄 = OpenProcess (2035711, 0, 进程ID)
日志框.加入文本 (“打开句柄:” + 到文本 (打开句柄) + #换行符)
.如果 (打开句柄 > 1)
    分配内存 = VirtualAllocEx (打开句柄, 0, 取字节集长度 (代码集), 4096, 4)
    日志框.加入文本 (“分配内存:” + 到文本 (分配内存) + #换行符)
    WriteProcessMemory_字节集 (打开句柄, 分配内存, 代码集, 取字节集长度 (代码集), 0)
    日志框.加入文本 (“代码集:” + 到文本 (代码集) + #换行符)
    线程句柄 = CreateRemoteThread (打开句柄, 0, 0, 分配内存, 0, 0, 0)
    日志框.加入文本 (“线程句柄” + 到文本 (线程句柄) + #换行符)
    WaitForSingleObject (线程句柄, -1)
    VirtualFreeEx (打开句柄, 分配内存, 取字节集长度 (代码集), 32768)
    CloseHandle (打开句柄)
    CloseHandle (线程句柄)
.否则
    信息框 (“打开句柄失败”, 0, , )





善者 慈悲心常在 无怨无恨 以苦为乐
默认压缩密码www.hifyl.com
文件分享密码问题:http://www.hifyl.com/read-htm-tid-4444.html
快速回复
限100 字节
批量上传需要先选择文件,再选择上传
 
上一个 下一个